Recent

Author Topic: Lazarus trunk now requires fpc 2.4.0  (Read 24833 times)

Paul Ishenin

  • Sr. Member
  • ****
  • Posts: 274
Lazarus trunk now requires fpc 2.4.0
« on: January 07, 2010, 09:17:58 pm »
I wrote a mail to the mail list some days ago that we are require fpc 2.4.0 or higher to compile lazarus from the svn trunk but some people are not subscribed and still don't know.

If you see some problem regards unit 'resource' which is now required by IDE then know you are using some older compiler than we need. Please switch to fpc 2.4.0 or fpc trunk (if you like hot features ;) ).

skalogryz

  • Global Moderator
  • Hero Member
  • *****
  • Posts: 2770
    • havefunsoft.com

bonmario

  • Sr. Member
  • ****
  • Posts: 346
Re: Lazarus trunk now requires fpc 2.4.0
« Reply #2 on: January 08, 2010, 09:21:01 am »
Exist a snapshot for windows with fpc 2.4.0?

stocki

  • Full Member
  • ***
  • Posts: 144
Re: Lazarus trunk now requires fpc 2.4.0
« Reply #3 on: January 08, 2010, 12:17:53 pm »

bonmario

  • Sr. Member
  • ****
  • Posts: 346
Re: Lazarus trunk now requires fpc 2.4.0
« Reply #4 on: January 08, 2010, 01:19:21 pm »
Thanks, i had this link http://snapshots.lazarus.shikami.org/lazarus/ for snapshots.
Now i added also your link in my bookmarks.


Troodon

  • Sr. Member
  • ****
  • Posts: 484
Re: Lazarus trunk now requires fpc 2.4.0
« Reply #5 on: January 08, 2010, 02:07:12 pm »
Is there any particular reason why there are Linux fpc-2.4.x rpm, but not deb, packages available for download in the Lazarus directory on the ftp server? Thanks.
« Last Edit: January 08, 2010, 02:14:16 pm by Troodon »
Lazarus/FPC on Linux

BeniBela

  • Hero Member
  • *****
  • Posts: 909
    • homepage
Re: Lazarus trunk now requires fpc 2.4.0
« Reply #6 on: January 08, 2010, 06:09:07 pm »
Has already someone created a binary package of a fpc 2.4.0 linux->win32 crosscompiler?
For 2.2.4 there was one in the Lazarus downloads...

zeljko

  • Hero Member
  • *****
  • Posts: 1607
    • http://wiki.lazarus.freepascal.org/User:Zeljan
Re: Lazarus trunk now requires fpc 2.4.0
« Reply #7 on: January 10, 2010, 01:27:19 pm »
yes, I've created cross win32 succesfully. Just follow
http://wiki.freepascal.org/Cross_compiling_for_Win32_under_Linux

bubulemaster

  • New Member
  • *
  • Posts: 47
Re: Lazarus trunk now requires fpc 2.4.0
« Reply #8 on: January 11, 2010, 04:37:48 pm »
Synapse library work with FPC 2.4.0 ?

I looked LNet library but I don't think it work cause, I found my_function(const a) ;

Could we replace FPC 2.2.4 on Lazarus 0.98.2 by FPC 2.4.0 ? Somebody have tested ?


theo

  • Global Moderator
  • Hero Member
  • *****
  • Posts: 1927
Re: Lazarus trunk now requires fpc 2.4.0
« Reply #9 on: January 11, 2010, 05:21:28 pm »
« Last Edit: January 11, 2010, 05:25:14 pm by theo »

BeniBela

  • Hero Member
  • *****
  • Posts: 909
    • homepage
Re: Lazarus trunk now requires fpc 2.4.0
« Reply #10 on: January 15, 2010, 07:16:08 pm »
yes, I've created cross win32 succesfully. Just follow
http://wiki.freepascal.org/Cross_compiling_for_Win32_under_Linux
Actually I would prefer to install an binary package of fpc instead compiling it from source, but nevermind

 

TinyPortal © 2005-2018