Recent

Author Topic: LAMW . [SOLVED] fatal error on first build after install using LAMW Manager  (Read 844 times)

edf_gingin

  • Newbie
  • Posts: 3
I get a fatal error on first build of project [LAMW] GUI Android Module after a new install  using LAMW Manager Installer for Windows.

This is on a Windows 10 PC which has not had lazarus installed before.
The error is listed below if you want to skip to it.
Does this error indicate the problem.

What I did
1) LAMW Manager (Linux and Windows)
used Install * LAMW Manager Installer for Windows

2) Config Paths
Lazarus IDE menu "Tools" >> "[LAMW] Android Module Wizard" >> "Paths Settings ..."

3) Create and Run your first Android Apk

From Lazarus IDE select "Project" >> "New Project"
From displayed dialog select "[LAMW] GUI Android Module" and "Ok"
Fill the form/dialog fields and "Ok"
saved Unit1 as suggested

From Lazarus IDE select "Run" >> "Build"
gave fatal error.

Mesages
I) verbose: selected chip architecture: armeami-v7a
I) verbose: Taking libraries from folder: C:\myproj\proj001\AppLAMWProject4\libs\armeami-v7a

Compile Project, OS: android, CPU arm, Target C:\myproj\proj001\AppLAMWProject4\libs\armeami-v7a\libcontrols.so: Exit code 1: Errors: 1
(-) Fatal: Cannot find system used by controls. Make sure all ppu files of a package are in its output directory. ppu in wrong directory =C:\lamw_manager\LAMW\LAMW4Windows\fpc\3.2.0\units\arm-android\rtl\system.ppu..

What does this mean. Is this fixable. Should I NOT use LAMW Manager Installer for Windows.
Which way of installing LAMW works.
By the way, after this I installed android studio. Worked without a problem. Dead easy. Prefer to use lazarus.

The following is just info incase it is needed

path to java JDK:
C:\lamw_manager\LAMW\jdk\zulu-default

path to Ant bin:
C:\lamw_manager\LAMW\apache-ant-1.10.5\bin

path to Gradle
C:\lamw_manager\LAMW\gradle-8.5

Path to Android NDK
C:\lamw_manager\LAMW\sdk\ndk-bundle

Path to  Android SDK
C:\lamw_manager\LAMW\sdk

I found the file LAMW.ini
[NewProject]
PathToWorkspace=C:\myproj\proj001
PathToJavaTemplates=C:\lamw_manager\LAMW\lazandroidmodulewizard\android_wizard\smartdesigner\java
PathToSmartDesigner=C:\lamw_manager\LAMW\lazandroidmodulewizard\android_wizard\smartdesigner
PathToJavaJDK=C:\lamw_manager\LAMW\jdk\zulu-default
PathToAndroidNDK=C:\lamw_manager\LAMW\sdk\ndk-bundle
PathToAndroidSDK=C:\lamw_manager\LAMW\sdk
PathToAntBin=C:\lamw_manager\LAMW\apache-ant-1.10.5\bin
PathToGradle=C:\lamw_manager\LAMW\gradle-8.5
PrebuildOSYS=windows-x86_64
MainActivity=App
FullProjectName=
InstructionSet=1
AntPackageName=org.lamw
AndroidPlatform=0
AntBuildMode=debug
NDK=5
NDKRelease=22.1.7171670
PackagePrefaceName=org.lamw

[JDKPaths]
0=C:\lamw_manager\LAMW\jdk\zulu-default

[SDKPaths]
0=C:\lamw_manager\LAMW\sdk

[GradlePaths]
0=C:\lamw_manager\LAMW\gradle-8.5

Thanks in advance for any assistance
« Last Edit: February 12, 2024, 11:07:12 am by edf_gingin »

nobody.00

  • New member
  • *
  • Posts: 7
Re: LAMW . fatal error on first build after install using LAMW Manager
« Reply #1 on: February 11, 2024, 10:26:44 am »
Because you choice armv7+solf and by default LAMW Manager uses (Android) Crosscompile to ARMv7+vFPV3
https://github.com/dosza/LAMWManager-win#cannot-build-lamw-demos
« Last Edit: February 11, 2024, 10:29:59 am by nobody.00 »

nobody.00

  • New member
  • *
  • Posts: 7
Re: LAMW . fatal error on first build after install using LAMW Manager
« Reply #2 on: February 11, 2024, 11:02:41 am »
get new release of lamw_manager and try later
https://github.com/dosza/LAMWManager-win/releases/tag/v0.3.1.8

marcos-ebm

  • New Member
  • *
  • Posts: 49
Re: LAMW . fatal error on first build after install using LAMW Manager
« Reply #3 on: February 11, 2024, 01:46:54 pm »
[using the translator]

As nobody.00 said, when you install from LAMW_MANAGER or FPCUPDELUXE, you have to choose the ARMv7a + VFPV3 option

the ARMv7a + Soft option is when you install Lamw manually
Lazarus 3.0 / LAMW 0.8.6.4 - Gradle 8.5 - Jdk 21 - Ndk 21e - Windows 11

edf_gingin

  • Newbie
  • Posts: 3
Re: LAMW . fatal error on first build after install using LAMW Manager
« Reply #4 on: February 12, 2024, 11:03:51 am »
Thanks for the helpful advice. instead of ARMV7a+Soft    i selected ARMV7a + VFPv3 and worked. Much appreaciated .

 

TinyPortal © 2005-2018