Recent

Author Topic: LAWM - Gradle Panic error  (Read 3214 times)

iru

  • Sr. Member
  • ****
  • Posts: 321
Re: LAWM - Gradle Panic error
« Reply #15 on: January 29, 2024, 11:26:31 am »
Gentefolk,
.
I have rebuilt Linux.

A check of the 'java'  shows:
@iru7280:~$ java --version

openjdk 11.0.21 2023-10-17
OpenJDK Runtime Environment (build 11.0.21+9-post-Ubuntu-0ubuntu122.04)
OpenJDK 64-Bit Server VM (build 11.0.21+9-post-Ubuntu-0ubuntu122.04, mixed mode, sharing)

NowI need to work out what to add, delete, update, etc.....

Ian





iru

  • Sr. Member
  • ****
  • Posts: 321
Re: LAWM - Gradle Panic error
« Reply #16 on: January 29, 2024, 09:44:30 pm »
Gentlefolk,

I have built a new version of Linux Mint. Applied all updates and upgrades.

I now have the following Java environment:

Ian

iru@iru7280:~$ java --version
openjdk 11.0.21 2023-10-17
OpenJDK Runtime Environment (build 11.0.21+9-post-Ubuntu-0ubuntu122.04)
OpenJDK 64-Bit Server VM (build 11.0.21+9-post-Ubuntu-0ubuntu122.04, mixed mode, sharing





iru

  • Sr. Member
  • ****
  • Posts: 321
Re: LAWM - Gradle Panic error
« Reply #17 on: January 31, 2024, 01:41:48 am »
Gentlefolk,

I have commenced adding the various android software systems to my linux system and am becoming a little confused.

There is a SDK and a JDK and the numerous explanationS  of the function and content on the WEB. I am more confused than usual....

Can any one explain the function, content and interrelationship of them???

Ian.

jmpessoa

  • Hero Member
  • *****
  • Posts: 2305
Re: LAWM - Gradle Panic error
« Reply #18 on: January 31, 2024, 02:09:41 am »
Lamw: Lazarus Android Module Wizard
https://github.com/jmpessoa/lazandroidmodulewizard

iru

  • Sr. Member
  • ****
  • Posts: 321
Re: LAWM - Gradle Panic error
« Reply #19 on: January 31, 2024, 11:57:02 am »
Thanks for your suggestion.
Even with two screens there is a llmited view of things....

I will print it and work my way through it, highlight things, cross things out see enough at once so I can make choices, etc....

Ian

iru

  • Sr. Member
  • ****
  • Posts: 321
Re: LAWM - Gradle Panic error
« Reply #20 on: February 04, 2024, 04:22:13 am »
Attempted to install LAWM as follows{

I have woIrked my through the LAMW document (https://github.com/jmpessoa/lazandroidmodulewizard).
I startedat 2, Infrastructure Setup :: only for non-users of "LAWM...."

Downloaded and installed
   JDK 21, Gradle 8.5 SDKj21

Executed 'sdkmanager "build-tools;34.0.0" "Platforms:android-34" "platform-tools".

Downloaded the NDK r21e.
Downloaded Gradle 8.5.

So I think I have everything required.

Used fpcupdeluxe to build a new 'stable' fpc and Laz environment.

In the LAZ IDE selected 'Package>Open Package file (.lpk)
Selected 'lazandroidmodulewizard-master/android-bridges/tfpandroidbridge_pack.lpk

In the package install window selected 'Install', etc.
When prompted selected 'Rebuild the IDE', etc the recompile/build of Laz commenced.

Failed-Linking error in the lazarus .LPR.....

make[2]: *** [Makefile:4362: lazarus] Error 1
make[1]: *** [Makefile:4801: ide] Error 2
*** [Makefile(3116,0) Error: linker: ide] Error 2
lazarus.pp(171,1) Error: Error while linking
lazarus.pp(171,1) Verbose: There were 1 errors compiling module, stopping
Verbose: Compilation aborted

I will think about things....

Ian

 

iru

  • Sr. Member
  • ****
  • Posts: 321
Re: LAWM - Gradle Panic error
« Reply #21 on: February 15, 2024, 10:18:24 am »
Gentlefolk,
I have had little time to work on this...

However I have managed to borrow a laptop with windows 10. Will load up LAZ and LAWM and see if I can get the job done.....

Ian.


marcos-ebm

  • New Member
  • *
  • Posts: 49
Re: LAWM - Gradle Panic error
« Reply #22 on: February 15, 2024, 11:36:39 am »
[using the translator]

download version 2.4.0c of fpcupdeluxe, as the stable version of lazaruas is version 3

after installing lazarus/fpc, install ARM - ANDROID

After that, you install LAMW (manually like you did)

When starting a new lamw project, always choose the ARMv7a+VFPv3 option
Lazarus 3.0 / LAMW 0.8.6.4 - Gradle 8.5 - Jdk 21 - Ndk 21e - Windows 11

 

TinyPortal © 2005-2018