Recent

Author Topic: [SOLVED] Cannot find laz_avl_Tree used by SymbolListHandler  (Read 2898 times)

Pep

  • Newbie
  • Posts: 5
[SOLVED] Cannot find laz_avl_Tree used by SymbolListHandler
« on: October 15, 2023, 03:29:39 pm »
I am struggling like hell trying to install fpc and lazarus on my system, the whole experience is making me feel like a linux noob, I honestly feel like I've gone back in time to a time when we used to install slackware from a stack of 3 inch floppies.

I have finally managed to install and compile fpc from a git download in my home directory, and finally managed to install and compile lazarus from a git download in my home directory. But every time I try to move forward I get slapped backwards. Both fpc and lazarus were downloaded from the main trunk.

So now my issue is that I can build a project all the way until I get this error message
Code: Pascal  [Select][+][-]
  1. symbollisthandler.pas(13,43) Error: Cannot find laz_avl_Tree used by SymbolListHandler of the Project Inspector.

I have opened the loaded package Lazutils and recompiled it with no errors.
The package has AvgLvlTree listed but not laz_avl_Tree.

After compiling the package I still get the same error.
The ide has highlighted this section in the project as an error
Code: Pascal  [Select][+][-]
  1. {$ifdef windows}
  2. uses
  3.   windows, Classes, SysUtils, AvgLvlTree, laz_avl_Tree, math, fgl, cvconst,
  4.   syncobjs, symbolhandlerstructs, DOM;
  5. {$endif}
With laz_avl_Tree highlighted.

Any ideas where I go next to solve this?
« Last Edit: October 15, 2023, 04:55:08 pm by Pep »

cdbc

  • Hero Member
  • *****
  • Posts: 1078
    • http://www.cdbc.dk
Re: Cannot find laz_avl_Tree used by SymbolListHandler
« Reply #1 on: October 15, 2023, 03:51:28 pm »
Hi
Have you tried: in Lazarus -> menu -> Project -> Project Inspector
... to add a requirement-package?!?
I think this is where your added laz-dependencies are housed...

edit: you've probably tried that. Sorry
Regards Benny
« Last Edit: October 15, 2023, 03:54:52 pm by cdbc »
If it ain't broke, don't fix it ;)
PCLinuxOS(rolling release) 64bit -> KDE5 -> FPC 3.2.2 -> Lazarus 2.2.6 up until Jan 2024 from then on it's: KDE5/QT5 -> FPC 3.3.1 -> Lazarus 3.0

Pep

  • Newbie
  • Posts: 5
Re: Cannot find laz_avl_Tree used by SymbolListHandler
« Reply #2 on: October 15, 2023, 04:00:06 pm »
I've just found the problem checking the git history.

It seems laz_avl_Tree was removed from Lazutils in the latest version of lazarus and the project I'm compiling is not up to date with lazarus.

But now I'm getting casting problems so it looks like maybe that has changed too somewhere along the way. I'm seriously regretting trying to sort this project out, I could probably do without it but my stubbornness is preventing that  ::)

cdbc

  • Hero Member
  • *****
  • Posts: 1078
    • http://www.cdbc.dk
Re: Cannot find laz_avl_Tree used by SymbolListHandler
« Reply #3 on: October 15, 2023, 04:07:51 pm »
Hi
What are your problems and which typecasting errors?!?
Maybe we can help  ;)
(?) can't you just use the normal (without laz in front) AvgLvlTree...
Regards Benny
If it ain't broke, don't fix it ;)
PCLinuxOS(rolling release) 64bit -> KDE5 -> FPC 3.2.2 -> Lazarus 2.2.6 up until Jan 2024 from then on it's: KDE5/QT5 -> FPC 3.3.1 -> Lazarus 3.0

Pep

  • Newbie
  • Posts: 5
Re: Cannot find laz_avl_Tree used by SymbolListHandler
« Reply #4 on: October 15, 2023, 04:42:41 pm »
Oh I solved the typecast error using my years of coding experience with multiple languages  8) but thanks for the offer.

I'm getting into other errors now but will move to a general lazarus language forum as they are not linux specific.

wp

  • Hero Member
  • *****
  • Posts: 11915
Re: [SOLVED] Cannot find laz_avl_Tree used by SymbolListHandler
« Reply #5 on: October 15, 2023, 05:16:22 pm »
At which level are your difficulties coming in? When you installed FPC and Lazarus, were you able to compile the empty project which opens at Lazarus startup? Or are your issues related to a specific project of yours? If yes: Which was the last Laz/FPC version for which it was working? Did you read the release notes of all versions between the last working and your current version regarding incompatibilities? (e.g. https://wiki.freepascal.org/Lazarus_3.0_release_notes - release notes of other versions are linked at the bottom of this page).

 

TinyPortal © 2005-2018