Recent

Author Topic: IDE windows - Locked in dock  (Read 627 times)

Nicole

  • Hero Member
  • *****
  • Posts: 509
IDE windows - Locked in dock
« on: July 18, 2022, 03:03:06 pm »
I used sucessfully the docking manager for the IDE windows.
Unfurtunately I lined up all windows from top to bottom by mistake.
Looong lines, narrow windows. :(

How can I bring one of them back so side by side?
Are there anywhere designs for downloading?

I just want my Delphi-IDE-Layout back....

af0815

  • Hero Member
  • *****
  • Posts: 1040
Re: IDE windows - Locked in dock
« Reply #1 on: July 18, 2022, 04:30:20 pm »
I used sucessfully the docking manager for the IDE windows.
Unfurtunately I lined up all windows from top to bottom by mistake.
Looong lines, narrow windows. :(

How can I bring one of them back so side by side?
Are there anywhere designs for downloading?

I just want my Delphi-IDE-Layout back....
You can delete the docking information or load a backup of your configuration. Yes it is possible to export and import this, but it is a learning curve.

BTW, i never use autostore of enviromentoptions. So i can simply close lazarus and all is good. If i change something in the enviroment (eg. docking) i do a manual store.
« Last Edit: July 18, 2022, 04:33:57 pm by af0815 »
regards
Andreas

Martin_fr

  • Administrator
  • Hero Member
  • *
  • Posts: 8483
  • Debugger - SynEdit - and more
    • wiki
Re: IDE windows - Locked in dock
« Reply #2 on: July 18, 2022, 04:51:59 pm »
If you have hidden the dock-handles, either in the config, or maybe in the context menu (of docking-tabs, if you have) you can enable them.

Then you can drag the dock-handles, and re-arrange everything.

Nicole

  • Hero Member
  • *****
  • Posts: 509
Re: IDE windows - Locked in dock
« Reply #3 on: July 18, 2022, 08:36:04 pm »
Thank you for your reply.
Unfortunately I have no idea, how to unhide this dock-handler. Cannot find it in the search.
I searched everywhere.
Somehow I must have done it to line up those windows, but I do not know how.

btw
I find nearly nothing there. I was used to hit F1 on anything and get smart in Delphi.

As Lazarus seems in many ways much smarter than Delphi, - how can I do it? (besides the docking problem)

Martin_fr

  • Administrator
  • Hero Member
  • *
  • Posts: 8483
  • Debugger - SynEdit - and more
    • wiki
Re: IDE windows - Locked in dock
« Reply #4 on: July 18, 2022, 10:04:37 pm »
https://wiki.freepascal.org/Anchor_Docking#Usage_I._.28Add_docking_support_to_the_Lazarus_IDE.29

I haven't gone through the page, but I guess it should have the answer.

The image has the "dock handles" highlighted with a red frame.

If you drag such a dock handle, the the docked window becomes loose, and can be docked somewhere else.

Nicole

  • Hero Member
  • *****
  • Posts: 509
Re: IDE windows - Locked in dock
« Reply #5 on: July 19, 2022, 10:42:20 am »
Thank you so much for the image!
I have wondered all the time, what these strange grafics may be! These were docking handles!
These were the good news.

The bad news: Those docking handles had dissappeared.
I could not find them anywhere anymore. I tried all the menues to make them visible. Nothing.

I am afraid, I uninstalled the AnchorDocking-thing for the second time.  :'(
It is a pity, because I liked this docking.
Is there another "better" docking manager? I am afraid not, beause it seems rather hard to write such a thing?

af0815

  • Hero Member
  • *****
  • Posts: 1040
Re: IDE windows - Locked in dock
« Reply #6 on: July 19, 2022, 01:11:36 pm »
I am afraid, I uninstalled the AnchorDocking-thing for the second time.  :'(
It is a pity, because I liked this docking.
You only need to reset the values. In your lazarus config dir you find a files called enviromentsoptions.xml back this up and go inside of Lazarus , select the splitter and click rigth, the activate 'show header'. Maybe you have mishit this.

Edit: It looks like indeed a bug. If you hit this, you will never can go back.

Close Lazarus. Open the enviromentsoptions.xml and search for a line with "Settings ShowHeader="False"" remove the ShowHeader="False" or change it to True. After reopen the dockings will be shown.

Quote
              </Item1>
            </Item1>
          </Nodes>
        </MainConfig>
        <Settings ShowHeader="False" SplitterWidth="3"/>
      </AnchorDocking>
    </Desktop2>
  </Desktops>
</CONFIG>

The SplitterWidth is the size of the splitter, normal = 4 i have changed this to 3

Backup: Go in Lazarus to menu Tools->Desktops... there is a Export Button - use this :-)

To avoid unwanted changes. Open the dialog and remove the autosave option. You can always store your changes with Save active desktop as.. and give the same name as before
« Last Edit: July 19, 2022, 01:20:54 pm by af0815 »
regards
Andreas

 

TinyPortal © 2005-2018