Recent

Author Topic: fpc not building on FreeBSD 12.1  (Read 524 times)

willbprog9933

  • Jr. Member
  • **
  • Posts: 53
    • BrainOut!
fpc not building on FreeBSD 12.1
« on: November 26, 2019, 08:53:01 pm »
Greetings all,

I am trying to build fpc on FreeBSD 12.1 amd64 per these instructions, but it is failing...

Code: Bash  [Select][+][-]
  1. $ export MAKE=`which gmake`
  2. $ $MAKE all OPT='-gl'
  3. <<<snip>>>
  4. gmake[3]: Leaving directory '/usr/home/will/Downloads/fpc_fixes_3_0/packages/fpmkunit'
  5. /usr/home/will/Downloads/fpc_fixes_3_0/compiler/ppcx64 fpmake.pp  -Fu/usr/home/will/Downloads/fpc_fixes_3_0/packages/fpmkunit/units_bs/x86_64-freebsd -Fu/usr/home/will/Downloads/fpc_fixes_3_0/rtl/units/x86_64-freebsd  -gl
  6. ./fpmake compile --localunitdir=.. --os=freebsd --cpu=x86_64 -o -Ur -o -Xs -o -O2 -o -n -o -Cg -o -gl -o -dx86_64 -o -dRELEASE --compiler=/usr/home/will/Downloads/fpc_fixes_3_0/compiler/ppcx64 -bu -o -XX -o -CX
  7. gmake[2]: *** [Makefile:1663: smart] Segmentation fault (core dumped)
  8. gmake[2]: Leaving directory '/usr/home/will/Downloads/fpc_fixes_3_0/packages'
  9. gmake[1]: *** [Makefile:2616: packages_smart] Error 2
  10. gmake[1]: Leaving directory '/usr/home/will/Downloads/fpc_fixes_3_0'
  11. gmake: *** [Makefile:2819: build-stamp.x86_64-freebsd] Error 2

The segfault is at the line with 'Makefile:1663: smart' in it.

Does anyone have any hints as to what I could do to resolve this?
« Last Edit: November 26, 2019, 09:12:57 pm by willbprog9933 »
Blessed and forgiven! :-D

marcov

  • Global Moderator
  • Hero Member
  • *****
  • Posts: 8491
  • FPC developer.
Re: fpc not building on FreeBSD 12.1
« Reply #1 on: November 26, 2019, 11:02:47 pm »
FreeBSD12 broke compatibility. Best is now to use the precompiled FreeBSD11 binaries under COMPAT

willbprog9933

  • Jr. Member
  • **
  • Posts: 53
    • BrainOut!
Re: fpc not building on FreeBSD 12.1
« Reply #2 on: November 26, 2019, 11:36:22 pm »
FreeBSD12 broke compatibility. Best is now to use the precompiled FreeBSD11 binaries under COMPAT

Thanks marcov.  I cannot do that, so I guess the 'last resort' is to use fixes branch on a Linux virtual machine.

:)
Blessed and forgiven! :-D

 

TinyPortal © 2005-2018