Recent

Author Topic: Will Lazarus support LLDB in High Sierra?  (Read 4065 times)

Igor Kokarev

  • Sr. Member
  • ****
  • Posts: 327
Will Lazarus support LLDB in High Sierra?
« on: August 14, 2018, 05:10:22 pm »
Hi,

Are there any plans to include support of LLDB debugger in Lazarus?

I've read all advices, Stackoverflow and official Lazarus Wiki and can't get to work GDB. macOS 10.13.6, Lazarus 1.8.4, fpc 3.0.4.
All suggestions didn't help.

Currently I can use only Xcode + ProjectXC to debug my apps in High Sierra.

I also tried VSCode + OmniPascal + Native Debugger, but couldn't configure correctly OmniPascal - it simply doesn't save any parameters in settings. Anyway I would prefer to use Lazarus than VCStudio.
« Last Edit: August 14, 2018, 05:13:20 pm by Igor Kokarev »

Trenatos

  • Hero Member
  • *****
  • Posts: 523
    • MarcusFernstrom.com
Re: Will Lazarus support LLDB in High Sierra?
« Reply #1 on: August 14, 2018, 05:55:42 pm »
https://forum.lazarus.freepascal.org/index.php?topic=37024.0

Haven't tried it, but this one says you can use lldb but have to do it from the commandline - https://alexconesa.wordpress.com/2016/11/16/lldb-and-gdb-debug-in-lazarus/

Martin_fr

  • Administrator
  • Hero Member
  • *
  • Posts: 7160
  • Debugger - SynEdit - and more
    • wiki
Re: Will Lazarus support LLDB in High Sierra?
« Reply #2 on: August 14, 2018, 06:10:59 pm »
Lazarus trunk already has basic support for lldb.

Install the package  components\lazdebuggers\lazdebuggerfplldb.lpk
(make sure it is the one with "fp" in the name)

Igor Kokarev

  • Sr. Member
  • ****
  • Posts: 327
Re: Will Lazarus support LLDB in High Sierra?
« Reply #3 on: August 15, 2018, 01:37:46 pm »
Thanks for your replies!

How I can install Lazarus trunk with LLDB on macOS?

UPD. I found how to install Beta version of Lazarus.
« Last Edit: August 16, 2018, 01:29:12 pm by Igor Kokarev »

dieselnutjob

  • Full Member
  • ***
  • Posts: 203
Re: Will Lazarus support LLDB in High Sierra?
« Reply #4 on: December 11, 2020, 05:04:17 pm »
Lazarus trunk already has basic support for lldb.

Install the package  components\lazdebuggers\lazdebuggerfplldb.lpk
(make sure it is the one with "fp" in the name)

Thank you for this reply.

I have just done a clean rebuild of my old MacBook Pro running High Sierra.
I installed fpc 3.20 directly downloaded from freepascal and then compiled Lazarus 2.1.0 from source.
Installing this package (where you said it would be) and then going into Lazarus -> Preferences -> Debugger -> Debugger backend and selecting LLDB debugger (with fpdebug) (Beta) works!
thanks again

 

TinyPortal © 2005-2018