Recent

Author Topic: TListView Index out of Bond when "Refreshing" under Windows  (Read 1284 times)

Adromir

  • New member
  • *
  • Posts: 6
In my form I have a ListView that gets filled with some Strings that I recieve from a commandline tool. On the GUI the User can set up a filter which Strings are shown. When the filter is applied, the Listview gets cleared and filled with new Values. It works fine if I run my program under Windows, but whenever i try that under Windows I get an "Index out of Bond" Error. If I continue with the Programm and apply the standard filter and refresh the Listview everything works fine again.

The only thing that changes is the Commandline that is sended by applying the Filter and the Output also is the Same under Windows and Linux.

Thank you in Advance
with best regards

Adromir

  • New member
  • *
  • Posts: 6
Re: TListView Index out of Bond when "Refreshing" under Windows
« Reply #1 on: July 16, 2018, 02:54:54 am »
I sorted it out. The Problem was in a RegEx i used to get the Items. Thread can be closed

Handoko

  • Hero Member
  • *****
  • Posts: 3759
  • My goal: build my own game engine using Lazarus
Re: TListView Index out of Bond when "Refreshing" under Windows
« Reply #2 on: July 16, 2018, 03:31:17 am »
Hello Adromir,
Welcome to the forum.

Good to hear you managed to solve the problem. Usually you will get replies quicker when asking coding related issue if you provide the source code. This forum has many skilled and helpful programmers.

 

TinyPortal © 2005-2018