Recent

Author Topic: Suse 9.1  (Read 7250 times)

mschnell

  • Full Member
  • ***
  • Posts: 131
    • http://www.lumino.de
Suse 9.1
« on: April 20, 2004, 12:04:03 pm »
Will Lazarus work on Suse 9.1 with Kernel 2.6 (due out at April 23)  ?

-Michael

cybermonkey342

  • Guest
Suse 9.1
« Reply #1 on: April 30, 2004, 03:23:52 pm »
I just installed SuSE 9.1 and I'm trying to use Lazarus. Seems that everything works fine, but the problem with SuSE: can't find lgtk! I changed the fpc.cfg just like posted in the FAQs, but the error still occurs. (Maybe anyone can help me with this?) So if Lazarus will find the gtk-libraries everything schoul work. I think you can use SuSE 9.1.

cybermonkey342

  • Guest
Suse 9.1
« Reply #2 on: May 02, 2004, 10:36:51 am »
Hello,

I solved the problem. I just copied the necessary library files to /usr/lib/ ! (I changed the fpc.cfg like posted in the FAQs, but that didn't work...).

So you can certainly use SuSE 9.1 and Lazarus. Everything works fine now!

mschnell

  • Full Member
  • ***
  • Posts: 131
    • http://www.lumino.de
Suse 9.1
« Reply #3 on: May 03, 2004, 09:10:37 am »
Thanks a lot for your reply.

I'll do the inssatllation ASAP.

-Michael

Vincent Snijders

  • Administrator
  • Hero Member
  • *
  • Posts: 2661
    • My Lazarus wiki user page
Suse 9.1
« Reply #4 on: May 03, 2004, 10:24:57 am »
Quote from: "cybermonkey342"
Hello,

 (I changed the fpc.cfg like posted in the FAQs, but that didn't work...).


How did you change the fpc.cfg? Did you make the changes in a fpc.cfg, that was used?

(Just trying to find out, what is wrong with the FAQ).

cybermonkey342

  • New Member
  • *
  • Posts: 42
    • Home of EGSL interpreter
Suse 9.1
« Reply #5 on: May 03, 2004, 11:16:34 am »
Quote from: "Vincent"
How did you change the fpc.cfg? Did you make the changes in a fpc.cfg, that was used?


If you mean, if the fpc.cfg was in use, no. I just changed the fpc.cfg which ist after the installation in the /etc/ path and then started Lazarus. Then tried to compile, but it seems the compiler didn't notify the change... (Maybe you should delete the old path within the fpc.cfg??)
(I know it's not very smart just to copy the files into the new path, but it works..)
--
Best regards

cybermonkey342

Vincent Snijders

  • Administrator
  • Hero Member
  • *
  • Posts: 2661
    • My Lazarus wiki user page
Suse 9.1
« Reply #6 on: May 03, 2004, 11:33:34 am »
Sorry for my English, I didn't mean in use, but (how should I say it) whether is was actually used by lazarus when compiling.

It seems somehow your changes weren't picked up by the compiler.

Would you like to try the following:
Open in lazarus the compiler options dialog (depending on which version you are using in the project or the run menu) and press the Test button.

Scan the output for a line containing:
Reading options from file ....
What file is mentioned there?
If it is /etc/fpc.cfg, check if there are line like
Handling option -Fl/opt/....
Interpreting option -Fl/opt/....
and further down
Using library path: /opt/....

TIA
Vincent.

cybermonkey342

  • New Member
  • *
  • Posts: 42
    • Home of EGSL interpreter
Suse 9.1
« Reply #7 on: May 03, 2004, 08:22:25 pm »
Hum, I would say the FAQs are okay... I think it could be my fault... because you have to put a symbolic link into the opt/gnome... lazarus find it.
So now I should start PROGRAMMING  :D
--
Best regards

cybermonkey342

 

TinyPortal © 2005-2018