Recent

Author Topic: Application.Helpcommand ??  (Read 5812 times)

Bart

  • Guest
Application.Helpcommand ??
« on: January 27, 2006, 04:32:59 pm »
Hi there,

This
Code: [Select]
begin
  Application.HelpFile := 'f:\lazarus projecten\test.hlp';
  if not Application.HelpCommand(HELP_CONTENTS,0) then ShowMessage('Error !');
end;

will allways give me the "Error !' message.
The file exists.

Running the same code in Delphi displays the helpfile as expected.

Did I do something wrong here?

It's getting very hard to get almost any common thing I do in Delphi to work in Lazarus. Just basic stuff like executing files, opening helpfiles, getting the application icon to work and show up in a TImage etc. etc.

Still not giving up though, just a steep learning curve I hope...

Bart

felipemdc

  • Administrator
  • Hero Member
  • *
  • Posts: 3541
RE: Application.Helpcommand ??
« Reply #1 on: February 01, 2006, 12:57:06 am »
I think this might haven´t being implemented yet, specifically since platform specific things have low priority.

You could try to use the Windows API directly for this.

Bart

  • Guest
Re: RE: Application.Helpcommand ??
« Reply #2 on: February 01, 2006, 10:34:33 am »
Quote from: "sekel"
I think this might haven´t being implemented yet, specifically since platform specific things have low priority.

Since the functionprototype exist, if it isn't implemented yet, at least I would have expected  to see some "Not implemented yet" message...
Quote from: "sekel"
You could try to use the Windows API directly for this.

I'll look into that.

Bart