Lazarus

Installation => Linux => Topic started by: goostudio on March 08, 2010, 09:21:25 am

Title: rpmlib(FileDigests) <= 4.6.0-1 is need , both in Redhat 9 and SUSE 11
Post by: goostudio on March 08, 2010, 09:21:25 am
I try to install Lazarus 0.9.28.2 on Redhat 9 and SUSE 11, all failed.

It says " rpmlib(FileDigests) <= 4.6.0-1 is need "

Does it mean my rpmlib's version is higher than 4.6.0-1???

And how can I deal with this problem , Help me please......

I googled this problem, but no solution for this.
Title: Re: rpmlib(FileDigests) <= 4.6.0-1 is need , both in Redhat 9 and SUSE 11
Post by: goostudio on March 12, 2010, 02:10:41 am
I meet same error in OpenSUSE 11.0.

Come on guys! Nobody Know?????
Title: Re: rpmlib(FileDigests) <= 4.6.0-1 is need , both in Redhat 9 and SUSE 11
Post by: julien2 on October 07, 2010, 03:52:18 pm
Hello

Did you find a solution, I have the same issue.

regards
Julien
Title: Re: rpmlib(FileDigests) <= 4.6.0-1 is need , both in Redhat 9 and SUSE 11
Post by: julien2 on October 07, 2010, 04:07:28 pm
ok, i compiled it from the sources and it seems ok !
Title: Re: rpmlib(FileDigests) <= 4.6.0-1 is need , both in Redhat 9 and SUSE 11
Post by: hemmrao on December 12, 2010, 06:45:05 am
ok, i compiled it from the sources and it seems ok !

Can you share please how you did it, thanks.
Title: Re: rpmlib(FileDigests) <= 4.6.0-1 is need , also an issue for RedHat EL 5.5
Post by: michael-newsrx on December 22, 2010, 04:55:03 pm
--> Running transaction check
---> Package lazarus.x86_64 0:0.9.28.2-0 set to be updated
--> Finished Dependency Resolution

Dependencies Resolved

==============================================================================================================================================================================
 Package                             Arch                               Version                                  Repository                                              Size
==============================================================================================================================================================================
Installing:
 lazarus                             x86_64                             0.9.28.2-0                               /lazarus-0.9.28.2-0.x86_64                             216 M

Transaction Summary
==============================================================================================================================================================================
Install       1 Package(s)
Upgrade       0 Package(s)

Total size: 216 M
Is this ok [y/N]: y
Downloading Packages:
Running rpm_check_debug
ERROR with rpm_check_debug vs depsolve:
rpmlib(FileDigests) is needed by lazarus-0.9.28.2-0.x86_64
Complete!
(1, [u'Please report this error in https://bugzilla.redhat.com/enter_bug.cgi?product=Red%20Hat%20Enterprise%20Linux%205&component=yum'])
[root@newsrxdb bin]#
Title: Re: rpmlib(FileDigests) <= 4.6.0-1 is need , also an issue for RedHat EL 5.5
Post by: michael-newsrx on December 22, 2010, 05:27:50 pm

---> Package lazarus.x86_64 0:0.9.28.2-0 set to be updated

Running rpm_check_debug
ERROR with rpm_check_debug vs depsolve:
rpmlib(FileDigests) is needed by lazarus-0.9.28.2-0.x86_64



The FPC rpm's installed just fine from the same download source on sourceforge:

$ rpm -qa|grep fpc
fpc-2.2.4-0
fpc-src-2.2.4-0
[root@newsrxdb bin]#
Title: Re: rpmlib(FileDigests) <= 4.6.0-1 is need , also an issue for RedHat EL 5.5
Post by: michael-newsrx on December 22, 2010, 06:05:05 pm

---> Package lazarus.x86_64 0:0.9.28.2-0 set to be updated

Running rpm_check_debug
ERROR with rpm_check_debug vs depsolve:
rpmlib(FileDigests) is needed by lazarus-0.9.28.2-0.x86_64



The FPC rpm's installed just fine from the same download source on sourceforge:

$ rpm -qa|grep fpc
fpc-2.2.4-0
fpc-src-2.2.4-0
[root@newsrxdb bin]#



https://bugzilla.redhat.com/show_bug.cgi?id=665073

seth vidal <svidal@redhat.com> changed:

          What    |Removed                     |Added
----------------------------------------------------------------------------
            Status|NEW                         |CLOSED
        Resolution|                            |NOTABUG
       Last Closed|                            |2010-12-22 11:48:46

--- Comment #1 from seth vidal <svidal@redhat.com> 2010-12-22 11:48:46 EST ---
the package lazarus was built with a newer version of rpm than the one in
rhel5. You should ask the provider of the pkg to [re]build it with these
rpmmacros enabled

%_source_filedigest_algorithm 0
%_binary_filedigest_algorithm 0


then it will work on rhel5.

--
Title: Re: rpmlib(FileDigests) <= 4.6.0-1 is need , both in Redhat 9 and SUSE 11
Post by: Marc on December 22, 2010, 07:02:20 pm
please bugrep in our bugtracker (if not done already)
Title: Re: rpmlib(FileDigests) <= 4.6.0-1 is need , both in Redhat 9 and SUSE 11
Post by: den4b on January 31, 2011, 02:38:05 pm
I stumbled upon the same issue which I started discussing here:
Failed to install Lazarus IDE on CentOS? (http://forum.lazarus.freepascal.org/index.php/topic,11983.0.html)

EDIT: I found a temporary solution! Extract the RPM package using a standard archive manager, e.g. File Roller.