Lazarus

Announcements => Third party => Topic started by: dmitryb on September 03, 2020, 07:57:25 pm

Title: fpcupdeluxe-x86_64-win64.exe libiconv-2.dll was not found.
Post by: dmitryb on September 03, 2020, 07:57:25 pm
Hi

Just installed "Stable" Lazarus 2.0.10 using fpcupdeluxe-x86_64-win64.exe

The installation went smoothly.
Lazarus starts without errors.
But when I try to start the simplest application, an error pops up.
See screenshot.
Title: Re: fpcupdeluxe-x86_64-win64.exe libiconv-2.dll was not found.
Post by: josh on September 03, 2020, 08:35:08 pm
Hi

I have had this too.

WHat I do is use the LazDebugger; which stops the above; and you also get to use the new debugger.

Top Menu Choose Packages->Install/Uninstall Packages
In the options that appear search for LazDebuggerFP 0.9 on the right hand side selection, double click it (it should then moe to the left hand side) and select Install Packages. You wil get a confirmation windows before it installs the package and rebuilds the IDE.
When it has restarted, you now need to tell the IDE to use the newly installed debugger as the debugger backend.
Tools->Options in the windows that appears scroll down the left side to Debugger and Click Debugger BackEnd; now click the dropdown arrow below the heading Debugger Type and Path and choose FPDebug internal DWarf Debugger. Finally click OK.

That should be it.

You may get an option windows when you run an app with debugger; it may ask what type of debuuger info you want to use I use Dwarf 3; or though Dwarf 2 works as well

Title: Re: fpcupdeluxe-x86_64-win64.exe libiconv-2.dll was not found.
Post by: dmitryb on September 03, 2020, 09:05:04 pm
I only have LazDebuggerFP 0.0 in the list.
Title: Re: fpcupdeluxe-x86_64-win64.exe libiconv-2.dll was not found.
Post by: josh on September 03, 2020, 09:15:41 pm
What happens if you use that one, my screenshots and info are from trunk version.
Title: Re: fpcupdeluxe-x86_64-win64.exe libiconv-2.dll was not found.
Post by: dmitryb on September 03, 2020, 09:28:12 pm
Yes

It works now. Thanks.
But at run-time it asked to disable -Xg.
So I did.
TinyPortal © 2005-2018