Lazarus

Announcements => Third party => Topic started by: Handoko on February 22, 2020, 02:18:11 pm

Title: GLScene OPM Installation Failed
Post by: Handoko on February 22, 2020, 02:18:11 pm
Today I'm interested to try GLScene, so I run Online Package Manager. Unfortunately I got "Error While Linking" issue when rebuilding the IDE (after picked/enabled the GLScene package).

I'm using Lazarus 2.0.6 64-bit Linux GTK2. Can anyone test installing it using OPM? Does it fail only on Linux? Or maybe there are some issues on my system?
Title: Re: GLScene OPM Installation Failed
Post by: GetMem on February 22, 2020, 03:03:55 pm
"Error While Linking" usually means that some libraries are not found, in this particular case libgl.so. I fixed the issue in my linux mint distribution by installing:
apt-get install libgl1-mesa-dev
apt-get install libglu1-mesa-dev
Title: Re: GLScene OPM Installation Failed
Post by: Handoko on February 22, 2020, 03:21:44 pm
Yes, you're right.

I've just reinstalled my system a while ago. My NVidia driver was perfectly installed and I can play games without problem.

Maybe it should be mentioned on OPM that those mesa dev packages are required.
Problem solved. Thank you.
Title: Re: GLScene OPM Installation Failed
Post by: BeanzMaster on February 23, 2020, 10:25:20 am
Hi Handoko, hum, i'm ttied install GLScene from OPM sometime ago on W10 and i haven't got problem if i'm remeber . I've also install GLScene manually on W10 Lazarus 2.0.6, no problem at all.

Can you try to do the installation normally. ? and tell me if you are a problem. Thanks in advance

@Getmem : With OPM installation , Are all packages compiled and installed ? if this is the case, actually only those GLScene_runtime and designTime  / GLScene_Physic_native / GLScene_OpenAL packages wich I am sure they work properly (and probably GLScene_Bass and GLScene_SDL packages but not tested) The others have many bugs.

[EDIT] the source must be taken from the Branches/GLSceneLCL folder in the sourceforge repository :
https://sourceforge.net/p/glscene/code/HEAD/tree/branches/GLSceneLCL/

For informations, actually i'm not doing any new big update in GLScene. This because since a little bit of 2 years, i'm writing a new library partially based on it. and it's a lot of work

Cheers

Title: Re: GLScene OPM Installation Failed
Post by: Handoko on February 23, 2020, 10:48:47 am
Just as GetMem said, GLScene on Linux requires some Linux packages. Simply installing libglu1-mesa-dev (which will automatically install some other packages) solved my problem.

I think it will better to mention, GLScene on Linux need to have libglu1-mesa-dev installed.

i'm writing a new library partially based on it. and it's a lot of work

If you finish and want to share it, please let us know.

I tested all the demos from the GLScene download, (almost) all of them can't run on Linux. I was able to fix most of them but some were too problematic, they automatically closed after some seconds of opening it. My conclusion is GLScene is not compatible with Linux. And it is good news if you want to create a 'better' version of GLScene. Please make it compatible with Linux.
Title: Re: GLScene OPM Installation Failed
Post by: BeanzMaster on February 23, 2020, 11:52:29 am
Thnaks Handoko i'll update the installation document for Linux.
I'll test also on my Linux distro just to see what's happen with the samples, but normally it should works (perhaps opengl definitions must be rewriting) when i'll have a little more time

And sure i'll keep you informed on the new library, the first Alpha stage (without 3D for now) will be available soon.

Thanks
Title: Re: GLScene OPM Installation Failed
Post by: GetMem on February 23, 2020, 03:30:18 pm
@Handoko
Quote
Maybe it should be mentioned on OPM that those mesa dev packages are required.
Adding a new node in OPM is not a problem, I can do it in no time, however documenting all the required libraries under linux is a massive task. Who's gonna do it?

@BeanzMaster
Quote
With OPM installation , Are all packages compiled and installed ?
Only GLScene_DesignTime.lpk and GLScene_RunTime.lpk. I will update the package soon from: https://sourceforge.net/p/glscene/code/HEAD/tree/branches/GLSceneLCL/
Title: Re: GLScene OPM Installation Failed
Post by: BeanzMaster on February 23, 2020, 07:00:13 pm
@Handoko
Quote
Maybe it should be mentioned on OPM that those mesa dev packages are required.
Adding a new node in OPM is not a problem, I can do it in no time, however documenting all the required libraries under linux is a massive task. Who's gonna do it?

Perhaps in the wiki, because it's just with GLScene but with all opengl. Not ?

@BeanzMaster
Quote
With OPM installation , Are all packages compiled and installed ?
Only GLScene_DesignTime.lpk and GLScene_RunTime.lpk. I will update the package soon from: https://sourceforge.net/p/glscene/code/HEAD/tree/branches/GLSceneLCL/

No problems Runtime and Designtime is sufficient all others package are addons and can be easly installed manually
Title: Re: GLScene OPM Installation Failed
Post by: Handoko on February 26, 2020, 05:13:24 am
@Handoko
Quote
Maybe it should be mentioned on OPM that those mesa dev packages are required.
Adding a new node in OPM is not a problem, I can do it in no time, however documenting all the required libraries under linux is a massive task. Who's gonna do it?

Perhaps in the wiki, because it's just with GLScene but with all opengl. Not ?

No, they're similar but different. TOpenGLControl requires (only) libgl1-mesa-dev, my system had installed properly and working good with TOpenGLControl. But it failed to compile/build with GLScene because GLScene also requires libglu1-mesa-dev.

For you information, installing libglu1-mesa-dev will automatically install libgl1-mesa-dev.
TinyPortal © 2005-2018