Lazarus

Programming => LCL => Topic started by: Bobito on November 13, 2019, 12:11:27 am

Title: can't install fpreport
Post by: Bobito on November 13, 2019, 12:11:27 am
Hi everyone, I downloaded trunk versions of Lazarus and Free Pascal, however i canĀ“t install fpreport.
Lazarus Version 2.1, Date 2019-11-09 svn revision 62218

I tried package-open package file\C:\fpcupdeluxe\lazarus\components\fpreport\lclfpreport.lpk

open-compile

but i get the message shown in the second attachment.
Title: Re: can't install fpreport
Post by: mangakissa on November 13, 2019, 08:47:32 am
you need zlib and freetype to install fpreports. It's in the manual
Title: Re: can't install fpreport
Post by: Bobito on November 13, 2019, 09:41:42 pm
Thanks a lot @mangakissa for your quick response. Now, where can I get: zlib, and freetype ? and the manual you refer to?

thanks again.
Title: Re: can't install fpreport
Post by: af0815 on November 14, 2019, 07:05:39 am
search for wiki and fpreport on google

but when did your message araise? if you build lazarus or if you build an app
Title: Re: can't install fpreport
Post by: Dio Affriza on November 14, 2019, 08:19:28 pm
If you see that screenshot you should know that when installing package!

Which wiki do you refer? Is that a frickin clear instruction? Holy moly.
You're trying on Windows, just give up already, that wiki never work.
Title: Re: can't install fpreport
Post by: lucamar on November 15, 2019, 11:25:45 am
He means a search for fpreport in the FPC/Lazarus Wiki (http://wiki.freepascal.org/) and, for good measure, in Google (or whatever your favourite search engine is).

Please, do note that for most FPC/Lazarus users English is not their mother-tongue so instructions may not always be "fricking clear" :)
TinyPortal © 2005-2018