Lazarus

Programming => Databases => Topic started by: JozeS on November 23, 2007, 07:51:01 am

Title: Problem with Lazarus 0.9.24 and ZEOSDBO-6.6.1-beta
Post by: JozeS on November 23, 2007, 07:51:01 am
When I compiling Zeos libary on Lazarus 0.9.24 I get error message box: "the packahe "zcomponent 6.5.1." faild to compile. Remove it from the installation list"
 In the Lazarus Source Editor i s marked:
{$IFDEF FPC}
const
  BaseFieldTypes: array[TFieldType] of TFieldType = (
    ftUnknown, ftString, ftInteger, ftInteger, ftInteger, ftBoolean, ftFloat,
    ftFloat, ftBCD, ftDateTime, ftDateTime, ftDateTime, ftBytes, ftVarBytes,
    ftInteger, ftBlob, ftBlob, ftBlob, ftBlob, ftBlob, ftBlob, ftBlob, ftUnknown,
    ftString, ftString, ftLargeInt, ftADT, ftArray, ftReference, ftDataSet,
    ftBlob, ftBlob, ftVariant, ftInterface, ftInterface, ftString, ftTimeStamp, ftFMTBcd);  

and in the message window:
C:\lazarus\components\ZEOSDBO-6.6.1-beta\src\component\ZAbstractRODataset.pas(3006,89) Fatal: Syntax error, "," expected but ")" found

In Lazarus 0.9.22. Zeos component is instaling without problem.

Any idea?
Title: Problem with Lazarus 0.9.24 and ZEOSDBO-6.6.1-beta
Post by: tatamata on November 23, 2007, 10:50:40 am
Hello.
You need to "recompile clean" every package in the list first, before installing.
But, my advice is the following: use current TESTING or TRUNK version of Zeoslib developer snapshots (http://zeosdownloads.firmos.at/downloads/snapshots/).
There is no such problem with recent developer snapshot. You will be able to install it immidiately. The testing branch has some additional features as well...I use recent testing version.

Regards,

Zlatko
Title: Problem with Lazarus 0.9.24 and ZEOSDBO-6.6.1-beta
Post by: bee on November 23, 2007, 11:27:41 am
I doubt the testing version is stable enough to be used on production environment. Why they don't release new version?
Title: Problem with Lazarus 0.9.24 and ZEOSDBO-6.6.1-beta
Post by: tatamata on November 23, 2007, 06:08:05 pm
From my experience, testing version is far more stable than the official "beta" version. I don't know why they don't release new official version. The whole site is very confusing. It is  even very difficult to find download location on the site. The web site is a piece of crap!
But the ZeosLib is a great thing! :P
Title: Problem with Lazarus 0.9.24 and ZEOSDBO-6.6.1-beta
Post by: Chris37 on November 24, 2007, 12:57:10 am
@ JoseS

For use Lazarus 0.9.24 with zeos 6.5.1 beta you can

-->in :
C:\lazarus\components\ZEOSDBO-6.6.1-beta\src\component\ZAbstractRODataset.pas(3006,

-->Replace :
BaseFieldTypes: array[TFieldType] of TFieldType = (
    ftUnknown, ftString, ftInteger, ftInteger, ftInteger, ftBoolean, ftFloat,
    ftFloat, ftBCD, ftDateTime, ftDateTime, ftDateTime, ftBytes, ftVarBytes,
    ftInteger, ftBlob, ftBlob, ftBlob, ftBlob, ftBlob, ftBlob, ftBlob, ftUnknown,
    ftString, ftString, ftLargeInt, ftADT, ftArray, ftReference, ftDataSet,
    ftBlob, ftBlob, ftVariant, ftInterface, ftInterface, ftString, ftTimeStamp, ftFMTBcd);


-->By

BaseFieldTypes: array[TFieldType] of TFieldType = (
    ftUnknown, ftString, ftInteger, ftInteger, ftInteger, ftBoolean, ftFloat,
    ftFloat, ftBCD, ftDateTime, ftDateTime, ftDateTime, ftBytes, ftVarBytes,
    ftInteger, ftBlob, ftBlob, ftBlob, ftBlob, ftBlob, ftBlob, ftBlob, ftUnknown,
    ftString, ftString, ftLargeInt, ftADT, ftArray, ftReference, ftDataSet,
    ftBlob, ftBlob, ftVariant, ftInterface, ftInterface,ftString, ftTimeStamp, ftFMTBcd , ftString,ftBlob );

-->And rebuild package !

Regards,
Chris   :D
TinyPortal © 2005-2018