Lazarus

Using the Lazarus IDE => General => Topic started by: Patrice68 on May 19, 2019, 07:34:37 pm

Title: Fortes report 324 an Lazarus 2.0.2 ... error ...
Post by: Patrice68 on May 19, 2019, 07:34:37 pm
Hello everyone,
Long-time user of Delphi, new in Lazarus (a few hours) :)

I downloaded and installed the latest version of Lazarus (# 2.0.2).
I found Fortes Report [url] https://sourceforge.net/projects/fortes4lazarus/files/fortesreport-3.24-LCL-R2.zip/download [/ url]
I opened Fortes324forlaz.lpk
And when I compile it, I have errors:
- rlprinters.pas (125,10) Error: Identify not found "OpenPrinter"
- rlprinters.pas (128,44) Error: incompatible type for arg no. 5: You have "Longword", wait for "PDWord"
- rlprinters.pas (133,58) Error: incompatible type for arg no. 5: You have "Longword", wait for "PDWord"

An article was published previously with identical problems but it was talking about Lazarus 0.9.30 ... there was a problem of version compatibility.

Is it not possible to compile FortesReport on Lazarus 2.0.2?
Title: Re: Fortes report 324 an Lazarus 2.0.2 ... error ...
Post by: Thausand on May 19, 2019, 07:54:04 pm
Hi hello Patrice68,

I no use self Fortez. You write have download manual but i think can find in OPM (http://wiki.freepascal.org/Online_Package_Manager) and maybe work better ?
Title: Re: Fortes report 324 an Lazarus 2.0.2 ... error ...
Post by: JanRoza on May 19, 2019, 08:37:38 pm
I use FortesReport CE which was installed via OPM and it compiles okay with Lazarus 2.0.2. Try that one.
Title: Re: Fortes report 324 an Lazarus 2.0.2 ... error ...
Post by: Patrice68 on May 21, 2019, 09:44:21 am
new in Lazarus ... I do not know "OPM"
works perfect!
thanks for the help  :)
Title: Re: Fortes report 324 an Lazarus 2.0.2 ... error ...
Post by: JanRoza on May 21, 2019, 12:10:22 pm
OPM (Online Package Manager) is already in your Lazarus installation you can find it in the Package menu. It's the easiest way to install a great variety of components (including FortesReport) into Lazarus. Highly recommended!