Lazarus

Installation => Mac OS X => Topic started by: b3ck3tt on October 27, 2018, 03:21:47 pm

Title: FPC 3.04 will not install on Mojave 10.14
Post by: b3ck3tt on October 27, 2018, 03:21:47 pm
I have Xcode 10.1beta3, installed the command line tools, still the installer complains about the HD. Thanks for any hints. Roman
Title: Re: FPC 3.04 will not install on Mojave 10.14
Post by: Jonas Maebe on October 27, 2018, 03:45:24 pm
Are you using the FPC 3.0.4 installer, or the FPC 3.0.4a installer? Only the FPC 3.0.4a installer will successfully install on macOS 10.14/with Xcode 10. Or do you mean that something changed in Xcode 10.1 so that the FPC 3.0.4a installer no longer works either?
Title: Re: FPC 3.04 will not install on Mojave 10.14
Post by: b3ck3tt on October 27, 2018, 04:12:02 pm
the 3.04a works, thank you very much! Roman
Title: Re: FPC 3.04 will not install on Mojave 10.14
Post by: mattias on July 03, 2019, 08:25:30 am
I uploaded the "a" version to the lazarus sourceforge site.
Title: Re: FPC 3.04 will not install on Mojave 10.14
Post by: HenrikErlandsson on September 09, 2019, 10:59:13 am
I have OS X Mojave 10.14.4 and XCode 10.2.1, the fpc 3.0.4a installer says it can't be installed because I need XCode and commandline tools. I followed the link (http://www.freepascal.org/down/i386/macosx-netherlands.var) in the message, but it gives me a 404 not found error. For me, the solution was to run xcode-select --install in Terminal.