Lazarus

Other Languages => Spanish => Topic started by: GAN on September 30, 2018, 08:17:27 pm

Title: Instalar dos versiones de Lazarus y Free Pascal
Post by: GAN on September 30, 2018, 08:17:27 pm
¿Hay algún método simple y seguro de mantener la versión que utilizo a diario Laz 1.6 FP 3.0.0 e instalar Laz 1.8.4 y FP 3.0.4 sin que se interfieran?
Si esto no fuese posible, calculo que para actualizar, deberé desinstalar todo e instalar Lazarus 1.8.4 desde cero lo que incluye también instalar los paquetes.

Title: Re: Instalar dos versiones de Lazarus y Free Pascal
Post by: lucamar on September 30, 2018, 10:22:29 pm
Depende de cómo definas "simple" y "seguro", pero mira en el wiki:
y similares. Otra opción es usar fpupdeluxe (http://wiki.freepascal.org/fpcupdeluxe), que es relativamente simple y bastante seguro.

Aunque en Linux ya se sabe: no se puede apostar. Igual todo va como la seda una vez y a la siguiente todo se tuerce desde el principio :D
Title: Re: Instalar dos versiones de Lazarus y Free Pascal
Post by: GAN on October 01, 2018, 02:27:19 am
Quote
Depende de cómo definas "simple" y "seguro", pero mira en el wiki:

Buena observación  :D Justamente los métodos de la wiki no me parecen ninguna de los dos...

Fpcupdeluxe pensaba que era para compilación cruzada nada más, veré si cobro coraje y lo instalo.

Quote
Aunque en Linux ya se sabe: no se puede apostar. Igual todo va como la seda una vez y a la siguiente todo se tuerce desde el principio

Ése es mi problema, la 1.6 la instalé hace 2 años sin ninguna dificultad y al día de hoy funciona todo.

Saludos.
Title: Re: Instalar dos versiones de Lazarus y Free Pascal
Post by: lucamar on October 01, 2018, 03:18:37 am
A no ser que tengas código que dependa de esa versión o que quieras conservarla por alguna razón, yo que tú desinstalaría e instalaría al menos la 1.8.4 Hay muchas cosas nuevas y mejoradas (¡y arregladas!) en ambos Lazarus 1.8 y FPC 3.0 que podrían hacerte la vida más fácil.

Además, es cuestión de meses para la salida de Lazarus 2 y, posiblemente, FPC 3.2, que incorporan aún más arreglos, etc. A decir verdad, en estos momentos yo sólo uso un Lazarus 1.6 para soportar las aplicaciones que tenemos para Windows 9x; en el resto de plataformas (MSDOS incluído!) usamos FPC 3.0.4 y Lazarus 1.8.4

En fin, ¡que tengas suerte! :)