Lazarus

Installation => General => Topic started by: htdroege on May 03, 2017, 09:52:54 pm

Title: Lazarus 1.6.4 (compiling my projects) with fpc 3.0.0 or 3.0.2
Post by: htdroege on May 03, 2017, 09:52:54 pm
Hello all;

I hope this is a simple question but I see that my install of Lazarus 1.6.4 has both 3.0.0 and 3.0.2 version of the compiler in the fpc directory.  Currently it is pointing to the 3.0.0 version in the 'Compiler executable' and Make executable paths of the Tools/Options dialog.  If I want to compile my projects using the new 3.0.2 version are these the only two setting that need to be repointed to 3.0.2?  Is there any other settings that need to be changed?

Finally, is there any reason not to use the fpc 3.0.2 version? 

Thanks, but I have searched high and low to verify this and cannot seem to find the answer anywhere.

Title: Re: Lazarus 1.6.4 (compiling my projects) with fpc 3.0.0 or 3.0.2
Post by: GetMem on May 04, 2017, 06:31:25 am
1. Close Lazarus
2. Rename  folder "FPC 3.0.0" to something else
3. Start Lazarus again, it will ask for compiler, fpc source, gdb, etc...Set the new paths to FPC 3.0.2
If you want to run different version of Lazarus/FPC in parallel use fpcdeluxe, the good thing is they won't interfere with each other.

PS: I would wait a few more weeks then switch to Lazarus 1.8.  A lot of new features, improvements, bug fixes.
Title: Re: Lazarus 1.6.4 (compiling my projects) with fpc 3.0.0 or 3.0.2
Post by: htdroege on May 04, 2017, 05:07:52 pm
Thanks for the information.  I will give it a try!

- Tom