Lazarus

Programming => Operating Systems => macOS / Mac OS X => Topic started by: pasquale on October 05, 2012, 07:34:13 pm

Title: Afraid of installing Lazarus 1.0
Post by: pasquale on October 05, 2012, 07:34:13 pm
Hello everybody,

I know this may sound crazy to many of you but, after reading the posts in this forum in which we can read that Lazarus stopped working on Mac OS X after installing the new version, I would like to ask you the following question: do you think that, if I just overwrote the previous version of the Lazarus binary file with the one shipped with version 1.0, Lazarus would work?

In other words, I would like to avoid installing the new package and just overwrite the old binary file with the new one. Do you know if this would be enough to upgrade to Lazarus 1.0?

Thanks in advance.
Title: Re: Afraid of installing Lazarus 1.0
Post by: jwdietrich on October 16, 2012, 01:14:30 am
I have upgraded four Mac installations of Lazarus 0.9.30 to version 1.0 and didn't observe any problem. Exactly the opposite is true - many issues with the previous versions have been solved with Lazarus 1.0.

Lazarus 1.0.2 requires Mac OS X 10.5 Leopard or newer, for Mac OS 10.4 Tiger I recommend Lazarus 1.0. Both versions work on PPC and Intel machines.
Title: Re: Afraid of installing Lazarus 1.0
Post by: pasquale on December 17, 2012, 08:48:17 pm
I have finally made up my mind to upgrade to Lazarus 1.0.4 and everything went fine. I just installed the new version without uninstalling the previous one and recompiled PowerPDF (the only external package I am currently using).