Installation => Linux => Topic started by: den4b on January 31, 2011, 01:25:17 pm

Title: Failed to install Lazarus IDE on CentOS? (RPMLIB dependancy problem workaround!)
Post by: den4b on January 31, 2011, 01:25:17 pm
Hi everyone,

I'm new to Lazarus on Linux, but not new to Lazarus and Linux on their own. I successfully installed Lazarus on Ubuntu platform and it went without a hitch. After installation links were added to the programming menu. IDE works.

Today, I tried installing Lazarus on CentOS 5.5. I downloaded and installed all 3 packages: fpc-src-2.2.4-0.i386.rpm, fpc-2.2.4-0.i386.rpm, lazarus- Installation did not report any problems (apart from "not signed" confirmation).

I found FPC in /usr/bin/fpc and FPC-SOURCE in /usr/share/fpcsrc/, but there is no sign of LAZARUS except an empty folder /etc/lazarus/. I searched the whole file system for "lazarus" and "lazres" without results (except that empty folder).

Can anyone help me understand what am I doing wrong??

Thank you!
Title: Re: How to start Lazarus IDE on CentOS?
Post by: Marc on January 31, 2011, 01:44:07 pm
to see where rpm has installed files you can use
rpm -q -l lazarus
Title: Re: How to start Lazarus IDE on CentOS?
Post by: den4b on January 31, 2011, 01:52:25 pm
I executed "rpm -q -l lazarus" and it replied with "package lazarus is not installed". Very strange, because installation process reported a successful installation. I installed it in the GUI mode with root.

Should I try installing in the terminal mode? Can anyone suggest a command line?

Thank you!
Title: Re: How to start Lazarus IDE on CentOS?
Post by: den4b on January 31, 2011, 02:29:19 pm
I tried running "rpm -ivh lazarus-" and that produced:

Code: [Select]
error: Failed dependencies:
        rpmlib(FileDigests) <= 4.6.0-1 is needed by lazarus-

I checked version of RPMLIB and it states "RPM version". The built-in package manager reports it as being up to date. I will try to force install the later version and will report back.
Title: Re: How to start Lazarus IDE on CentOS?
Post by: den4b on January 31, 2011, 02:33:25 pm
I found the same problem described in a different thread:
rpmlib(FileDigests) <= 4.6.0-1 is need , both in Redhat 9 and SUSE 11 (,8834.0.html)

No resolution was found...
Title: Re: How to start Lazarus IDE on CentOS?
Post by: Marc on January 31, 2011, 02:57:32 pm
if this is the only failing dependency, you can try "rpm -ivh --nodeps lazarus-"
to skip dependency checking. I see no reason why we require certain rpm versions
Title: Re: How to start Lazarus IDE on CentOS?
Post by: den4b on January 31, 2011, 03:39:56 pm
Code: [Select]
[root@localhost ~]# rpm -ivh --nodeps lazarus-
Preparing...                ########################################### [100%]
   1:lazarus                ########################################### [100%]
error: unpacking of archive failed on file /etc/lazarus/editoroptions.xml;4d46c844:
cpio: MD5 sum mismatch

The dependency error is logical because the RPM packager used for creating the package is newer and probably uses new features which are not available in current RPM library. This might explain the failed checksum.

I also tried YUM and it also complained about the same dependency:

Code: [Select]
[root@localhost ~]# yum --nogpgcheck install lazarus-
Loaded plugins: fastestmirror
Loading mirror speeds from cached hostfile
 * addons:
 * base:
 * extras:
 * updates:
Setting up Install Process
Examining lazarus- lazarus-
Marking lazarus- to be installed
Resolving Dependencies
--> Running transaction check
---> Package lazarus.i586 0: set to be updated
--> Finished Dependency Resolution

Dependencies Resolved

 Package       Arch       Version          Repository                      Size
 lazarus       i586       /lazarus-       242 M

Transaction Summary
Install       1 Package(s)
Upgrade       0 Package(s)

Total size: 242 M
Is this ok [y/N]: y
Downloading Packages:
Running rpm_check_debug
ERROR with rpm_check_debug vs depsolve:
rpmlib(FileDigests) is needed by lazarus-
(1, [u'Please report this error in
Post by: den4b on January 31, 2011, 03:53:05 pm

I extracted RPM package using the standard archive manager (File Roller 2.16.0) and it WORKED! Even the icon in the Applications -> Programming -> Lazarus have appeared! I started the IDE and compiled the example project with one form = all works!! :)

You must install all 3 packages using a standard package manager and then extract the contents of lazarus package manually, below are the steps.

1) Install fpc-2.2.4-0.i386.rpm,
2) Install fpc-src-2.2.4-0.i386.rpm,
3) Install lazarus- (this step is still necessary because it will install all of the dependencies, but will fail to install the lazarus itself)
4) Manually extract contents of lazarus-, using a standard archive manager.

Nevertheless, the dependency problem for installing directly via RPM or YUM needs some resolution!

Maybe developers can comment on this?
Post by: JuhaManninen on February 03, 2011, 02:00:31 pm
Maybe developers can comment on this?

FPC 2.2.4 and Lazarus are rather old and not much energy should be wasted with them now.
There is a new Lazarus release coming, I hope it will improve the installation on CentOS.

If you want to see how much Lazarus has improved, you can do it already before the release.
Just install the latest FPC 2.4.2 release and its source package from repo or from an RPM.
Then in ~:
$  svn co lazarus
$ cd lazarus
$ make all
$ ./lazarus &

You must have gtk2-devel (or similar) package installed when compiling Lazarus. This is true also for the older 0.9.28 release.
Make sure you don't have many versions of FPC or Lazarus installed at the same time (to avoid potential problems).

TinyPortal © 2005-2018