Lazarus

Using the Lazarus IDE => General => Topic started by: Alextp on March 31, 2021, 08:47:47 pm

Title: [Solved] Cannot build IDE trunk from 2021.03.31
Post by: Alextp on March 31, 2021, 08:47:47 pm
FPC 3.2 fixes
IDE trunk from graemeg's Git

Quote
(3104) Compiling sourcesyneditor.pas
(3104) Compiling etsrceditmarks.pas
(3104) Compiling sourcemarks.pas
(3104) Compiling keymapping.pp
make[2]: *** [Makefile:5105: idepkg] Error 2
make[1]: *** [Makefile:3685: idepkg] Error 2
/home/user/fpcupdeluxe/fpcupdeluxe/lazarus/ide/editoroptions.pp(7124,1) Error: (9031) Can't open resource file "/home/user/fpcupdeluxe/fpcupdeluxe/lazarus/ide/editoroptions.res"
/home/user/fpcupdeluxe/fpcupdeluxe/lazarus/ide/editoroptions.pp(7124,1) Fatal: (10026) There were 1 errors compiling module, stopping
Fatal: (1018) Compilation aborted
Error: /home/user/fpcupdeluxe/fpcupdeluxe/fpc/bin/x86_64-linux/ppcx64 returned an error exitcode
make: *** [Makefile:3691: useride] Error 2
Error: (lazarus) Build IDE: stopped with exit code 2
Error: (lazarus) Building IDE: Building IDE failed.
fpcupdeluxe: ERROR: LazarusNativeInstaller (BuildModuleCustom: UserIDE): make returned exit status #512


ERROR: Fpcupdeluxe fatal error !
Title: Re: Cannot build IDE trunk from 2021.03.31
Post by: Martin_fr on March 31, 2021, 09:35:10 pm
My fault. give me a minute
Title: Re: Cannot build IDE trunk from 2021.03.31
Post by: Martin_fr on March 31, 2021, 09:38:12 pm
fixed in r64896 / not sure how long until Graeme's git will have it
TinyPortal © 2005-2018