Lazarus

Using the Lazarus IDE => Options => Topic started by: a.mcneill on September 18, 2004, 08:19:51 am

Title: Compile error
Post by: a.mcneill on September 18, 2004, 08:19:51 am
Ok, when I try to compile an app, or lazarus itself, i receive a compiler error, "/usr/share/lazarus/lcl/interfaces/gtk2/interfaces.pas(31,16) Fatal: Can't find unit INTERFACEBASE, so I set the options to "gtk" instead of "gtk2" and I get the same error as above except its now ".../gtk/interfaces.pas/...".  I am using SuSE 9.1 with KDE 3.3 update.  I know that the files are there, I located them yet lazarus seems to believe that they are not.  Is there an environment option that I am missing?
Title: Compile error
Post by: Marc on September 18, 2004, 06:41:28 pm
Some questions
* how do you compile your app
* what version/type of lazarus did you use  (cvs or package)
* what version/type of fpc did you use  (cvs or package)
* what version/type of fpc sources did you use  (cvs or package)

from the warning I guess that you have the /usr/share/lazarus/lcl/interfaces/gtk dir as part of your search path (in fpc.cfg) this one shouldn't be there
TinyPortal © 2005-2018