Recent

Author Topic: Program crashes on 10.5, works on 10.6  (Read 3713 times)

Martin V

  • Full Member
  • ***
  • Posts: 139
Program crashes on 10.5, works on 10.6
« on: July 24, 2010, 05:16:33 pm »
Hello,

I have ported my two editors to Lazarus and published MacOSX versions. See Third party announcements and:
http://www.hypermake.com/english/betatest.html

A user which uses Leopard (10.5) reports for both editors:

--------------------
OS X gives the following error message:

/Applications/wsedit.app/Contents/MacOS/wsedit ; exit;
GriffWoodiMac:~ DrPhilGA$
/Applications/wsedit.app/Contents/MacOS/wsedit ; exit;dyld: unknown
required load command 0x80000022
Trace/BPT trap
logout
--------------------

On my 10.6 system, all works fine. Any ideas? What are your test results?

Martin

skalogryz

  • Global Moderator
  • Hero Member
  • *****
  • Posts: 2181
    • havefunsoft.com
Re: Program crashes on 10.5, works on 10.6
« Reply #1 on: July 24, 2010, 08:31:48 pm »
It appears you have compiled the program without 10.5 compatibility!

add a linker option to your project compiler's option:
Code: [Select]
-macosx_version_min 10.5
Of course, your Xcode must be installed with 10.5 support!

added to the wiki
« Last Edit: July 24, 2010, 08:48:11 pm by skalogryz »
Patron Cocoa Widgetset development https://www.patreon.com/skalogryz