Forum > General

Is there a non-installation version of Lazarus?

<< < (2/2)


have fun, just follow what Theo said

I also have built one, but it's not really perfect. I'll try winpenpack version.

Same 'problem' here.
Just make it easy for yourself:
- install Lazarus on another PC (or virtual PC for that matter) in exactly the same directory as you want to use it on the target machine;
- zip the installed directory;
- unzip on the target machine with the same folder structure.

Works like a charm! (I don't use QT so maybe you should copy that file manually.)
Minor problem: if you reinstall a new Lazarus version, you need to reinstall/rebuild the packages.

On a side note: the QT lib is installed in c:\windows\system32 which is a serious bug in Lazarus. This is something that should have been fixed a long time ago.

Goodman H__:

--- Quote from: theo on July 06, 2010, 12:36:08 pm ---So you didn't copy from:
C:\lazarus to C:\lazarus but something like
C:\lazarus to C:\whatever\lazarus ?

Maybe you should have a look at the file fpc.cfg then

--- End quote ---

Yes,exactly.I tried again with same folder structure,it works now.

Thank you all for all your help!

BTW,then is anybody here would like to do me a favour ,just to share your copy of lazarus which can use sqlite3 without problem.I have tried handreds of time to install-uninstall-download another copy of laz and install again but never can use sqlite3 with laz.Three main problems found on different versions/installations under winxp:

1.can not save new records even I have below code followed by the reply of one of my post in the forum regarding laz can not write back new record to sqlite3 db.

--- Code: ---
//under dbgrid click evet:
if button=nbpost then SQLQuery.applyupdate;

//or apply below in a button and let it do the save record job:


--- End code ---

There is no problem with my sqlite3.dll since I use it everywhere with my c++.

or 2.DataGrid can not hold the value you typed,when the focus leaves any of the columns,the value hold in this column disappears.
or 3.When edit 'SQL (TstringList)' in a sqlquery control,after I wrote "select * from mydb;" and press the green left-arrow button,it says "no such table: mytable",of course mydb is right there and under some installation this problem disappears,but under some installation,it appears again.


[0] Message Index

[*] Previous page

Go to full version