Forum > macOS / Mac OS X

"unknown stabs type" error

(1/2) > >>

Well, I am stuck. At this point I believe it may be because of the recent XCode 3.2.2 update. I've tried reverting to previous versions of both FPC and Lazarus, but I still get that "unknown stabs type" when compiling Lazarus or a Lazarus project (and an access violation when I attempt to run one of my compiled projects, but not Lazarus).

Has anybody else upgraded XCode to 3.2.2 and experienced this problem (or not)?

Ok, I think I've found the problem. It is indeed an XCode issue. Passing -gw2 to make when building Lazarus eliminates the "unknown stabs type" errors and the linking errors when building projects. To build Lazarus, I did "make all OPT="-gw2 -godwarfsets" and it compiled fine.

Jonas Maebe:
FWIW, it's not Xcode 3.2.2-specific. It already started with Xcode 3.0. It is indeed a bug in the Xcode linker.

Jonas Maebe:

--- Quote from: jmaebe on April 30, 2010, 07:27:05 am ---FWIW, it's not Xcode 3.2.2-specific. It already started with Xcode 3.0. It is indeed a bug in the Xcode linker.

--- End quote ---

And for the record: this problem does not cause access violations. It only makes stepping into functions/procedures with locally defined symbolic constants impossible. Your crashing problems were caused by something else.

Well, yes and no. Yes, I did in fact have an issue in one of my projects that was causing a crash. However, Lazarus itself crashes when trying to debug anything now, even a bare-bones "Form1"-default project. At first I assumed it was because I didn't have the project being compiled with the same options as Lazarus. But then I made sure it was being compiled with the "-gw2 -godwarfsets" options, and it's still a no-go. Sometimes the app won't even load in the debugger. If it does, trying to stop the debugger crashes Lazarus, giving the "Access violation" message. Always. And simply exiting the running project app crashes Lazarus every time, too, which I'm assuming is because doing so exits the debugger.

I'm not sure if this is because of the new gdb in XCode 3.2.2 or what. This version say "Apple version gdb-1461.2" and doing a search on that version reveals all of 6 results, so it is pretty new.

Anyway, something is going on here, and I can't figure out how to get around this debugging issue.


[0] Message Index

[#] Next page

Go to full version