Forum > General

Can't find unit laz_acs used by Lazarus

(1/1)

davesimplewear:
I am trying to install ACS components in lazarus 0.9.29 FPC 2.5.1 on linux and get the message Can't find unit laz_acs used by Lazarus when trying to install, the unit is in the path and available, so what am I doing wrong?

Regards
Dave

JuhaManninen:

--- Quote from: davesimplewear on April 23, 2010, 06:19:53 am ---I am trying to install ACS components in lazarus 0.9.29 FPC 2.5.1 on linux and get the message Can't find unit laz_acs used by Lazarus when trying to install, the unit is in the path and available, so what am I doing wrong?

--- End quote ---

I can confirm it but I don't know why it happens. The file is auto-generated by Lazarus and has the same base name as the package itself.
It registers the package like this:
----------
procedure Register;
begin
  RegisterUnit('acs_reg', @acs_reg.Register);
end;

initialization
  RegisterPackage('laz_acs', @Register);
end.
---------

I guess it has worked before. When did it stop working?
Other package I tested now worked OK.
This package has many unit search paths. Could it affect this problem?

Juha

davesimplewear:
Thanks Juha, which other package worked? I downloaded the svn package, this is the one that I had the error message from.

Regards
Dave

JuhaManninen:

--- Quote from: davesimplewear on April 24, 2010, 11:41:37 pm ---Thanks Juha, which other package worked? I downloaded the svn package, this is the one that I had the error message from.

--- End quote ---

I tested some other packages I had around and they compiled and installed fine.
It means this is a ACS specific problem and not for example Lazarus version specific problem.
I also got ACS from svn because the other download link did not work.

Juha

davesimplewear:
Is there anyone who has installed the svn version of ACS in linux?

Navigation

[0] Message Index

Go to full version