Recent

Author Topic: Can't find unit laz_acs used by Lazarus  (Read 5410 times)

davesimplewear

  • Sr. Member
  • ****
  • Posts: 314
    • Davids Freeware
Can't find unit laz_acs used by Lazarus
« on: April 23, 2010, 06:19:53 am »
I am trying to install ACS components in lazarus 0.9.29 FPC 2.5.1 on linux and get the message Can't find unit laz_acs used by Lazarus when trying to install, the unit is in the path and available, so what am I doing wrong?

Regards
Dave
All things considered insanity seems the best option

JuhaManninen

  • Global Moderator
  • Hero Member
  • *****
  • Posts: 4107
  • I like bugs.
Re: Can't find unit laz_acs used by Lazarus
« Reply #1 on: April 23, 2010, 09:16:38 am »
I am trying to install ACS components in lazarus 0.9.29 FPC 2.5.1 on linux and get the message Can't find unit laz_acs used by Lazarus when trying to install, the unit is in the path and available, so what am I doing wrong?

I can confirm it but I don't know why it happens. The file is auto-generated by Lazarus and has the same base name as the package itself.
It registers the package like this:
----------
procedure Register;
begin
  RegisterUnit('acs_reg', @acs_reg.Register);
end;

initialization
  RegisterPackage('laz_acs', @Register);
end.
---------

I guess it has worked before. When did it stop working?
Other package I tested now worked OK.
This package has many unit search paths. Could it affect this problem?

Juha
Mostly Lazarus trunk and FPC 3.2 on Manjaro Linux 64-bit.

davesimplewear

  • Sr. Member
  • ****
  • Posts: 314
    • Davids Freeware
Re: Can't find unit laz_acs used by Lazarus
« Reply #2 on: April 24, 2010, 11:41:37 pm »
Thanks Juha, which other package worked? I downloaded the svn package, this is the one that I had the error message from.

Regards
Dave
All things considered insanity seems the best option

JuhaManninen

  • Global Moderator
  • Hero Member
  • *****
  • Posts: 4107
  • I like bugs.
Re: Can't find unit laz_acs used by Lazarus
« Reply #3 on: April 25, 2010, 07:06:12 am »
Thanks Juha, which other package worked? I downloaded the svn package, this is the one that I had the error message from.

I tested some other packages I had around and they compiled and installed fine.
It means this is a ACS specific problem and not for example Lazarus version specific problem.
I also got ACS from svn because the other download link did not work.

Juha
Mostly Lazarus trunk and FPC 3.2 on Manjaro Linux 64-bit.

davesimplewear

  • Sr. Member
  • ****
  • Posts: 314
    • Davids Freeware
Re: Can't find unit laz_acs used by Lazarus
« Reply #4 on: April 25, 2010, 11:28:13 am »
Is there anyone who has installed the svn version of ACS in linux?
All things considered insanity seems the best option

 

TinyPortal © 2005-2018