Recent

Author Topic: Lazarus kills on startup  (Read 21602 times)

Davide Gurgone

  • New member
  • *
  • Posts: 8
Lazarus kills on startup
« on: April 08, 2010, 12:09:37 am »
hi all,
I'm quite new to lazarus.

Yesterday I successfully ported on mac os x an MS Windows application, but today, after updating sources, lazarus could not start itself.

I can see Lazarus Icon appears and disappears in a few seconds.

Exists a startup log to make a trouble diagnose or, better, someone knows the way to solve it?

Thanks a lot,
Davide.

skalogryz

  • Global Moderator
  • Hero Member
  • *****
  • Posts: 2520
    • havefunsoft.com
Re: Lazarus kills on startup
« Reply #1 on: April 08, 2010, 06:08:30 am »
Exists a startup log to make a trouble diagnose or, better, someone knows the way to solve it?

You can try to launch the lazarus from the Terminal:

Code: [Select]
cd to_lazarus_directory
./Lazarus.app/Contents/MacOS/lazarus

copy all the output here.
Patron Cocoa Widgetset development https://www.patreon.com/skalogryz

Davide Gurgone

  • New member
  • *
  • Posts: 8
Re: Lazarus kills on startup
« Reply #2 on: April 08, 2010, 12:05:34 pm »
Hi,
Thank's a lot for your reply!

I launched lazarus from terminal, it logs a lot of things, than starts itself properly.  I don't know why.

After terminal launch, I opened again lazarus, but now double clicking on icon, than I selected newer project sources.. Now both, Lazarus and my application runs...

I really don't understand...

Ciao, Davide.
 

riko

  • New Member
  • *
  • Posts: 13
Re: Lazarus kills on startup
« Reply #3 on: May 18, 2010, 04:06:27 pm »
Hello all,
i am new to lazarus and have found this post which meets my problem - Lazarus stops immediately after starting.
I have tryed the suggestion from "skalogryz" and tried to start from terminal.

Following output after start:

my-mac-pro:lazarus riko$ ./Lazarus.app/Contents/MacOS/lazarus
[FORMS.PP] ExceptionOccurred
  Sender=EPrinter
  Exception=Printer " " does't exists.
  Stack trace:
  $00737E2A
  $007366D1
  $0073640A
  $00737705
TApplication.HandleException Printer " " does't exists.
  Stack trace:
  $00737E2A
  $007366D1
  $0073640A
  $00737705
exception at 00737E2A:
Printer " " does't exists.
my-mac-pro:lazarus riko$

What is this printer??
I have installed 3 printers. But no one with name " "....

Any ideas? Please help....

Thanks riko.

skalogryz

  • Global Moderator
  • Hero Member
  • *****
  • Posts: 2520
    • havefunsoft.com
Re: Lazarus kills on startup
« Reply #4 on: May 19, 2010, 02:00:15 am »
1) do you have any printers installed?

2) what's Lazarus version you're using?

3) what's OSX version (intel or powerpc)

The problem is with printer's component. It's expected to be fixed in the trunk (snapshots versions). It could be resolved by rebuilding Lazarus without these components or by installing newer Lazarus version.
Patron Cocoa Widgetset development https://www.patreon.com/skalogryz

skalogryz

  • Global Moderator
  • Hero Member
  • *****
  • Posts: 2520
    • havefunsoft.com
Re: Lazarus kills on startup
« Reply #5 on: May 19, 2010, 02:00:48 am »
1) do you have any printers installed?

2) what's Lazarus version you're using?

3) what's OSX version and CPU (intel or powerpc)?

The problem is with printer's component. It's expected to be fixed in the trunk (snapshots versions). It could be resolved by rebuilding Lazarus without these components or by installing newer Lazarus version.
Patron Cocoa Widgetset development https://www.patreon.com/skalogryz

riko

  • New Member
  • *
  • Posts: 13
Re: Lazarus kills on startup
« Reply #6 on: May 19, 2010, 04:44:27 am »
Hello,
thanks for your reply..

1) i have installed 3 printers (one of them is online).

2+3) i have downloaded the latest version for mac osx intel. Following the install log:

May 18 19:34:26 riko-mac-pro Installer[2435]: Hardware: MacPro3,1 @ 2.80 GHz (x 8 ), 10240 MB RAM
May 18 19:34:26 riko-mac-pro Installer[2435]: Running OS Build: Mac OS X 10.6.3 (10D573)
May 18 19:34:26 riko-mac-pro Installer[2435]: Env: PATH=/usr/bin:/bin:/usr/sbin:/sbin
May 18 19:34:26 riko-mac-pro Installer[2435]: Env: TMPDIR=/var/folders/Wg/WgST5KVIHPShOSKPyBT7a++++TI/-Tmp-/
May 18 19:34:26 riko-mac-pro Installer[2435]: Env: SHELL=/bin/bash
May 18 19:34:26 riko-mac-pro Installer[2435]: Env: HOME=/Users/riko
May 18 19:34:26 riko-mac-pro Installer[2435]: Env: USER=riko
May 18 19:34:26 riko-mac-pro Installer[2435]: Env: LOGNAME=riko
May 18 19:34:26 riko-mac-pro Installer[2435]: Env: DISPLAY=/tmp/launch-UitPxH/org.x:0
May 18 19:34:26 riko-mac-pro Installer[2435]: Env: SSH_AUTH_SOCK=/tmp/launch-NJxmHo/Listeners
May 18 19:34:26 riko-mac-pro Installer[2435]: Env: Apple_PubSub_Socket_Render=/tmp/launch-PV62Kf/Render
May 18 19:34:26 riko-mac-pro Installer[2435]: Env: COMMAND_MODE=unix2003
May 18 19:34:26 riko-mac-pro Installer[2435]: Env: __CF_USER_TEXT_ENCODING=0x1F5:0:3
May 18 19:34:26 riko-mac-pro Installer[2435]: Free Pascal Compiler  Installation Log
May 18 19:34:26 riko-mac-pro Installer[2435]: Opened from: /Volumes/fpc-2.2.4.intel-macosx/fpc-2.2.4.intel-macosx.pkg
May 18 19:34:26 riko-mac-pro Installer[2435]: fileURLForURL = x-disc://fpc-2.2.4.intel-macosx/fpc-2.2.4.intel-macosx.pkg
May 18 19:34:26 riko-mac-pro Installer[2435]: fileURLForURL = file://localhost/Volumes/fpc-2.2.4.intel-macosx/fpc-2.2.4.intel-macosx.pkg
May 18 19:35:05 riko-mac-pro runner[2440]: Administrator authorization granted.
May 18 19:35:05 riko-mac-pro Installer[2435]: ================================================================================
May 18 19:35:05 riko-mac-pro Installer[2435]: User picked Standard Install
May 18 19:35:05 riko-mac-pro Installer[2435]: Choices selected for installation:
May 18 19:35:05 riko-mac-pro Installer[2435]:    Aktualisieren: "Free Pascal Compiler"
May 18 19:35:05 riko-mac-pro Installer[2435]:       fpc-2.2.4.intel-macosx.pkg : org.freepascal.fpc : 2.2.4.2.2
May 18 19:35:05 riko-mac-pro Installer[2435]: ================================================================================
.
.
May 18 19:35:43 riko-mac-pro Installer[2515]: ================================================================================
May 18 19:35:43 riko-mac-pro Installer[2515]: User picked Standard Install
May 18 19:35:43 riko-mac-pro Installer[2515]: Choices selected for installation:
May 18 19:35:43 riko-mac-pro Installer[2515]:    Aktualisieren: "FPC Xcode templates"
May 18 19:35:43 riko-mac-pro Installer[2515]:       fpc-xcode-2.2.4.pkg : org.freepascal.xcode : 2.2.4.2.2
May 18 19:35:43 riko-mac-pro Installer[2515]: ================================================================================
.
.
May 18 19:36:24 riko-mac-pro Installer[2526]: ================================================================================
May 18 19:36:24 riko-mac-pro Installer[2526]: User picked Standard Install
May 18 19:36:24 riko-mac-pro Installer[2526]: Choices selected for installation:
May 18 19:36:24 riko-mac-pro Installer[2526]:    Aktualisieren: "Free Pascal Sources"
May 18 19:36:24 riko-mac-pro Installer[2526]:       fpcsrc-2.2.4-20090929.pkg : org.freepascal.fpc.source : 2.2.4.2.24
May 18 19:36:24 riko-mac-pro Installer[2526]: ================================================================================
.
.
May 18 19:37:19 riko-mac-pro Installer[2539]: ================================================================================
May 18 19:37:19 riko-mac-pro Installer[2539]: User picked Standard Install
May 18 19:37:19 riko-mac-pro Installer[2539]: Choices selected for installation:
May 18 19:37:19 riko-mac-pro Installer[2539]:    Aktualisieren: "Lazarus"
May 18 19:37:19 riko-mac-pro Installer[2539]:       lazarus.pkg : org.freepascal.lazarus.www : 0.9.28.0.9282
May 18 19:37:19 riko-mac-pro Installer[2539]: ================================================================================

« Last Edit: May 19, 2010, 04:47:35 am by riko »

riko

  • New Member
  • *
  • Posts: 13
Re: Lazarus kills on startup
« Reply #7 on: May 19, 2010, 05:06:19 am »
Hello,

since i don't know how to rebuild lazarus without the printing components, i have tried somewhat else.

I have installed one of my printers again with the name " "...and guess what...it works...lazarus starts up without an error.
Thank you again...

riko.

riko

  • New Member
  • *
  • Posts: 13
Re: Lazarus kills on startup
« Reply #8 on: May 19, 2010, 05:49:26 am »
Ok, I had rejoiced too soon...

1) mac-os renames the " " printer after closeing the systemsettings to "_"...afterwards lazarus stops running again

2) i cant run a simple application from IDE...
a lot of warnings like

Code: [Select]
ld: warning: unknown stabs type 0xE0 in /Developer/lazarus/lcl/units/i386-darwin/comctrls.o
ld: warning: unknown stabs type 0xC0 in /Developer/lazarus/lcl/units/i386-darwin/filectrl.o
ld: warning: unknown stabs type 0xE0 in /Developer/lazarus/lcl/units/i386-darwin/filectrl.o
ld: warning: unknown stabs type 0xC0 in /Developer/lazarus/lcl/units/i386-darwin/carbon/carbonwsdialogs.o

and

[TCompiler.Compile] end
[TCmdLineDebugger] Debug PID: 557
TGDBMIDebugger.ProcessResult Error: ,msg="No symbol table is loaded.  Use the \"file\" command."
[Debugger] Running GDB version: Apple version gdb-1461.2
[TDebugger.SetFileName] "/tmp/project1.app"
[TMainIDE.DoRunProject] B TGDBMIDebugger
TGDBMIDebugger.StartDebugging WorkingDir="/tmp/"
TGDBMIDebugger.ProcessResult Error: ,msg="No symbol \"FPC_THREADVAR_RELOCATE_PROC\" in current context."
[Debugger] Log output: &"info functions FPC_CPUINIT\n"
[Debugger] Log output: &"info address main\n"
[Debugger] Log output: &"info file\n"
[Debugger] File type: mach-o-le
[Debugger] Entry point: 0x00002650
[WARNING] Debugger: Unexpected async-record: =shlibs-updated
[Debugger] Log output: &"info program\n"
[WARNING] Debugger: Unknown record: macosx_debug_inferior_status: current status:
[WARNING] Debugger: Unknown record:               inferior task: 0x4103
[WARNING] Debugger: Unknown record:                 [SIGNAL THREAD]
[WARNING] Debugger: Unknown record: macosx_debug_inferior_status: information on debugger task:
[WARNING] Debugger: Unknown record: macosx_debug_inferior_status: information on inferior task:
[WARNING] Debugger: Unknown record: macosx_debug_inferior_status: information on debugger threads:
[WARNING] Debugger: Unknown record:   thread: 0x60f
[WARNING] Debugger: Unknown record:   thread: 0x1703
[WARNING] Debugger: Unknown record:   thread: 0x1b03
[WARNING] Debugger: Unknown record:   thread: 0x2003
[WARNING] Debugger: Unknown record:   thread: 0x3903
[WARNING] Debugger: Unknown record:   thread: 0x4303
[WARNING] Debugger: Unknown record:   thread: 0x4503
[WARNING] Debugger: Unknown record: macosx_debug_inferior_status: information on inferior threads:
[WARNING] Debugger: Unknown record:   thread: 0x4203
TDebugger.ReqCmd failed: Run
[TMainIDE.DoRunProject] END

Afterwards i can only "halt" the project...

Any suggestions?

skalogryz

  • Global Moderator
  • Hero Member
  • *****
  • Posts: 2520
    • havefunsoft.com
Re: Lazarus kills on startup
« Reply #9 on: May 19, 2010, 06:43:25 am »
Since i don't know how to rebuild lazarus without the printing components, i have tried somewhat else.

I have installed one of my printers again with the name " "...and guess what...it works...lazarus starts up without an error.
Thank you again...

1st)  To rebuild the lazarus open Terminal "cd" to Lazarus directroy and run command "make"
this should rebuild the Lazarus, removing Printers components.

However, riko, do you have time and wish to fix the printers bug? I cannot reproduce the error on my Mac. However users are experiencing the problem from time-to-time and it needs to be fixed.

2nd) if you want to run an application from IDE, you can try to switch the debugger off. (environment->Options->Debugger select "none") Otherwise, fixing debugging issues, might require some additional information from you, see this thread: http://forum.lazarus.freepascal.org/index.php/topic,7411.60.html
« Last Edit: May 19, 2010, 06:46:15 am by skalogryz »
Patron Cocoa Widgetset development https://www.patreon.com/skalogryz

riko

  • New Member
  • *
  • Posts: 13
Re: Lazarus kills on startup
« Reply #10 on: May 19, 2010, 06:46:01 am »
Hello,

yes if i can i will try to fix the problem...how?

skalogryz

  • Global Moderator
  • Hero Member
  • *****
  • Posts: 2520
    • havefunsoft.com
Re: Lazarus kills on startup
« Reply #11 on: May 19, 2010, 06:52:11 am »
yes if i can i will try to fix the problem...how?

You'll need to get Lazarus from SVN trunk.

run Terminal and execute following commands there
Code: [Select]
cd ~
svn co http://svn.freepascal.org/svn/lazarus/trunk lazarus
this will take some time (and internet traffic)
don't close the Terminal. after checkout execute following commands
Code: [Select]
cd lazarus
make
this should build lazarus.
open the newly built IDE with the command:
Code: [Select]
open lazarus.app
in Environment->Files change "Lazarus directory" to "/Users/you_user_name/lazarus"
Patron Cocoa Widgetset development https://www.patreon.com/skalogryz

riko

  • New Member
  • *
  • Posts: 13
Re: Lazarus kills on startup
« Reply #12 on: May 19, 2010, 08:04:19 am »
Ok, it's done.

During compile there where a lot of warnings like...
Code: [Select]
ld: warning: unknown stabs type 0xC0 in /Users/riko/Entwicklung/lazarus/components/synedit/units/i386-darwin/synregexpr.o
ld: warning: unknown stabs type 0xE0 in /Users/riko/Entwicklung/lazarus/components/synedit/units/i386-darwin/synregexpr.o
ld: warning: unknown stabs type 0xC0 in /Users/riko/Entwicklung/lazarus/lcl/units/i386-darwin/filectrl.o
ld: warning: unknown stabs type 0xE0 in /Users/riko/Entwicklung/lazarus/lcl/units/i386-darwin/filectrl.o
ld: warning: unknown stabs type 0xC0 in /Users/riko/Entwicklung/lazarus/lcl/units/i386-darwin/ldocktree.o

But it startsup now with no error...also the debugger works...i have not changed any code...

riko.

riko

  • New Member
  • *
  • Posts: 13
Re: Lazarus kills on startup
« Reply #13 on: May 19, 2010, 08:14:31 am »
I have seen some miss behaivior in the editor of the IDE.
If the Antialiasing is switched off and you mark some lines they move...also if you edit the line the characters are destroyed...

riko.

skalogryz

  • Global Moderator
  • Hero Member
  • *****
  • Posts: 2520
    • havefunsoft.com
Re: Lazarus kills on startup
« Reply #14 on: May 19, 2010, 08:40:25 am »
If the Antialiasing is switched off and you mark some lines they move...also if you edit the line the characters are destroyed...
what's your editor font setting?
Patron Cocoa Widgetset development https://www.patreon.com/skalogryz

 

TinyPortal © 2005-2018