Recent

Author Topic: glscene cannot be installed  (Read 9641 times)

Anonymous

  • Guest
glscene cannot be installed
« on: March 10, 2005, 03:22:33 pm »
Hi!

I'm new here and use Lazarus 0.9.6 for Windows. When I try to install the glscene-component (see http://glscene.sourceforge.net/index.php) package (an .ipk-file) which is specially made for Lazarus with the sources of the latest version I get everytime the same error:
"can't find unit GlScanlinedGraphics".
It would be great if anyone could help me to solve this problem because I really need the library.

Thank you very much.

Lightning

  • Sr. Member
  • ****
  • Posts: 422
glscene cannot be installed
« Reply #1 on: March 15, 2005, 11:11:53 am »
Try this package by lod__ http://avl.ath.cx/glscene.zip
I tested it on Linux and it's OK, should work on windows too :)
The future must be... Fast and OpenSource so...
Think Open and Lightning Fast!

Anonymous

  • Guest
glscene cannot be installed
« Reply #2 on: March 17, 2005, 02:25:43 pm »
I now use the newest beta version of lazarus. There seems to be a bug. Trying to install any package, the following error appears:
LazarusWin\glscenelazarus.pas(6,2) Fatal: Syntax error, "BEGIN" expected but "." found

The line which causes the problem is:
.unit GLSceneLazarus;

It seems the package-manager generates wrong units for packages.

Lightning

  • Sr. Member
  • ****
  • Posts: 422
glscene cannot be installed
« Reply #3 on: March 18, 2005, 12:46:08 pm »
Lazarus has ONLY beta version, people even use the CVS to update.
Why the dot on that line ? Of course it's wrong, remove the dot !
The package manager has nothing to do with it, this is NOT a Lazarus BUG.
The future must be... Fast and OpenSource so...
Think Open and Lightning Fast!

Anonymous

  • Guest
glscene cannot be installed
« Reply #4 on: March 18, 2005, 03:45:28 pm »
I open the glscenelazarus.lpk file in Lazarus and try to install it. But after a couple of moments, the compiler stops because of this error message at a file called glscenelazarus. See the following code:

.unit GLSceneLazarus;

interface

uses
  GLMisc, VectorGeometry, OpenGL1x, VectorTypes, Spline, VectorLists,
    PersistentClasses, XOpenGL, GLTexture, GLGraphics, GLUtils,
    GLCrossPlatform, GLContext, GLState, XCollection, GeometryBB, Polynomials,
    GLStrings, GLWin32Context, GLLCLViewer, GLSilhouette, GLScene, GLObjects,
    GLTeapot, GLGeomObjects, GLBehaviours, GLLazarusRegister,
    ApplicationFileIO, Info, FVectorEditor, GLSceneEditNew, LazarusPackageIntf;

implementation

procedure Register;
begin
  RegisterUnit('GLLazarusRegister', @GLLazarusRegister.Register);
  RegisterUnit('ApplicationFileIO', @ApplicationFileIO.Register);
end;

initialization
  RegisterPackage('GLSceneLazarus', @Register);
end.

It doesn't use anything to remove this point and to recompile, the package isn't installed. I don't know why this error occurs.

Lightning

  • Sr. Member
  • ****
  • Posts: 422
glscene cannot be installed
« Reply #5 on: March 24, 2005, 09:55:39 pm »
This line ".unit GLSceneLazarus; " is a Pascal syntax error the dot is expected after the last END or when using types/objects but never vefore a token !!!
You source is broken, also use search on the forum to see other posts related to GLScene :)
The future must be... Fast and OpenSource so...
Think Open and Lightning Fast!

Marc

  • Administrator
  • Hero Member
  • *
  • Posts: 2531
glscene cannot be installed
« Reply #6 on: March 25, 2005, 02:18:20 pm »
This dot is a bug in the german translation of the comment before the dot. It is fixed in CVS. If you don't use CVS, simply remove the dot.
//--
{$I stdsig.inc}
//-I still can't read someones mind
//-Bugs reported here will be forgotten. Use the bug tracker

Anonymous

  • Guest
glscene cannot be installed
« Reply #7 on: March 25, 2005, 04:54:19 pm »
Thanks for your answer, I just turned to the English version but however I can't get any package of glscene compiled. Trying to compile, lazarus shows me that there are always units missed or some errors in the code, I don't know why.

Anonymous

  • Guest
glscene cannot be installed
« Reply #8 on: March 27, 2005, 12:53:42 pm »
With the neweset Win32 installer snapshot I've no problems any more to install the package :D.
Thanks for supporting me!

 

TinyPortal © 2005-2018