Forum > PDAs and Smartphones

Icon on exe file


Hi all,

i tried to attach some icons to my project executable but not successfull.

going on Menu/Project/ProjectOptions/Load Icon, i choose a new icon to the project. The size was the default icon size, 32x32.
After build, the icon shown was the lazarus default tiger foot icon.

If i remove the icon, it removes correctly. The compiled file have no icon.

I tried to edit my project.rc file containing this line
MAINICON ICON "project.ico" 
and add this compilation parameter on projetc.lpr file
{$IFDEF WINDOWS}{$R TesteMob.rc}{$ENDIF}
, with and without ifdef windows, but again the default icon appear.

the icon file have the same name as the project file.

my lazarus version is beta (25/10/2009)
FPC : 2.2.4

there is any problem on lazarus or i'm doing something wrong?


....mmm, strange, no problem here.
Same version, of Lazarus and FPC.
Try another icon, if still not working, create a dumb project and post it somewhere.

Well, starting a new project it worked perfectly.


Same problem. beta

FPC Version 3.0.4

Go to Projects-Project Options - Application Settings
Clear Icon
Load Icon, select from where the desirable icon is located
Click OK

The Application Executable will get the new Icon that you will have selected.


[0] Message Index

Go to full version