Recent

Author Topic: Problem with VideoTest Linux  (Read 8075 times)

klacus

  • New Member
  • *
  • Posts: 20
Problem with VideoTest Linux
« on: December 02, 2010, 08:07:13 am »
Hi Folks.

I have a following troubles when I try to compile the VideoTest.lpr.

"
TFMainForm.pas(82,27) Hint: Parameter "Src" not used
/usr/bin/ld: warning: /home/kozma/Dokumentumok/lazarus/VideoTest/lib/i386-linux/link.res contains output sections; did you forget -T?
/usr/bin/ld: cannot find -lglib
VideoTest.lpr(19,1) Error: Error while linking
VideoTest.lpr(19,1) Fatal: There were 1 errors compiling module, stopping
"

I use Lazarus 0.9.28.2
Ubuntu 10.10.

What a frick is -lglib? Any dependency, or what?  Any package need for run?

I want to use my webcam, the system can handle it ex. skype. So I don't know what's wrong...
Please help me.

Best Regards
Laszlo


Blaazen

  • Hero Member
  • *****
  • Posts: 2922
  • POKE 54296,15
    • Eye-Candy Controls
Re: Problem with VideoTest Linux
« Reply #1 on: December 02, 2010, 06:44:16 pm »
Hi, I use Kubuntu, the same version like you. I think lglib could be libglib. Try open your package manager and write libglib. You will see what will be found.
Lazarus 2.1.0 r63940 FPC 3.3.1 r40507 x86_64-linux-qt Chakra, Qt 4.8.7/5.13.2, Plasma 5.17.3
Lazarus 1.8.2 r57369 FPC 3.0.4 i386-win32-win32/win64 Wine 3.21

Try Eye-Candy Controls: https://sourceforge.net/projects/eccontrols/files/

klacus

  • New Member
  • *
  • Posts: 20
Re: Problem with VideoTest Linux
« Reply #2 on: December 03, 2010, 04:12:43 am »
Hello.

Thanks for your reply.

Unfortunately I have it. I tried to install other modules, but no function.

B.R.
L.

 


klacus

  • New Member
  • *
  • Posts: 20
Re: Problem with VideoTest Linux
« Reply #3 on: December 03, 2010, 04:43:07 am »
Hi, I use Kubuntu, the same version like you. I think lglib could be libglib. Try open your package manager and write libglib. You will see what will be found.

klacus@csysc-desc-design:~$ dpkg -l libgtk*
Desired=Unknown/Install/Remove/Purge/Hold
| Status=Not/Inst/Conf-files/Unpacked/halF-conf/Half-inst/trig-aWait/Trig-pend
|/ Err?=(none)/Reinst-required (Status,Err: uppercase=bad)
||/ Név           Verzió        Leírás
+++-==============-==============-============================================
un  libgtk-directf <nincs>        (nincs leírás)
ii  libgtk-vnc-1.0 0.4.1-3ubuntu2 A VNC viewer widget for GTK+ (runtime librar
ii  libgtk2-perl   2:1.222-1      Perl interface to the 2.x series of the Gimp
un  libgtk2-perl-d <nincs>        (nincs leírás)
ii  libgtk2.0-0    2.22.0-0ubuntu The GTK+ graphical user interface library
ii  libgtk2.0-0-db 2.22.0-0ubuntu The GTK+ libraries and debugging symbols
ii  libgtk2.0-bin  2.22.0-0ubuntu The programs for the GTK+ graphical user int
ii  libgtk2.0-cil  2.12.10-1      CLI binding for the GTK+ toolkit 2.12
ii  libgtk2.0-cil- 2.12.10-1      CLI binding for the GTK+ toolkit 2.12
ii  libgtk2.0-comm 2.22.0-0ubuntu Common files for the GTK+ graphical user int
ii  libgtk2.0-dev  2.22.0-0ubuntu Development files for the GTK+ library
un  libgtk2.0-doc  <nincs>        (nincs leírás)
un  libgtkada2-bin <nincs>        (nincs leírás)
ii  libgtkgl2.0-1  2.0.1-1build1  OpenGL context support for GTK+ (shared libr
ii  libgtkgl2.0-de 2.0.1-1build1  OpenGL context support for GTK+ (development
ii  libgtkglext1   1.2.0-1.1fakes OpenGL Extension to GTK+ (shared libraries)
ii  libgtkhtml-edi 1:3.30.3-1ubun HTML rendering/editing library - editor widg
ii  libgtkhtml-edi 1:3.30.3-1ubun HTML rendering/editing library - editor widg
un  libgtkhtml3.14 <nincs>        (nincs leírás)
ii  libgtkhtml3.14 1:3.30.3-1ubun HTML rendering/editing library - runtime fil
un  libgtkhtml3.14 <nincs>        (nincs leírás)
un  libgtkmm-2.4-1 <nincs>        (nincs leírás)
un  libgtkmm-2.4-1 <nincs>        (nincs leírás)
ii  libgtkmm-2.4-1 1:2.20.3-1     C++ wrappers for GTK+ (shared libraries)
ii  libgtksourcevi 2.10.5-0ubuntu shared libraries for the GTK+ syntax highlig
ii  libgtksourcevi 2.10.5-0ubuntu common files for the GTK+ syntax highlightin
un  libgtksourcevi <nincs>        (nincs leírás)
ii  libgtkspell0   2.0.16-1       a spell-checking addon for GTK's TextView wi

Bart

  • Hero Member
  • *****
  • Posts: 3919
    • Bart en Mariska's Webstek
Re: Problem with VideoTest Linux
« Reply #4 on: December 03, 2010, 01:27:06 pm »
The message probably refers to not finding the glib library.

ld prepends a "-l" before the filename if it is a library.

sudo apt-get install glib ?

You probably need the glib-devel package as well.

Bart

klacus

  • New Member
  • *
  • Posts: 20
Re: Problem with VideoTest Linux
« Reply #5 on: December 06, 2010, 05:01:21 am »
I already have it....

davesimplewear

  • Sr. Member
  • ****
  • Posts: 307
    • Davids Freeware
Re: Problem with VideoTest Linux
« Reply #6 on: December 06, 2010, 07:59:41 am »
use synaptic or apt-get and install libglib-dev
All things considered insanity seems the best option

l_netwalker

  • Newbie
  • Posts: 2
Re: Problem with VideoTest Linux
« Reply #7 on: February 05, 2011, 12:49:01 pm »
Hi all,

got the same error!
So I searched a bit and set the following:
TFMainForm.pas:
change glib to glib2 in the uses clause
RGBGTKRoutines.pas:
insert: {$DEFINE LCLgtk2} after the interface statement

Now everything compiles, but I get only a black image from my 2 different cams.
Seems the same problem as in my post about 5dpo, my cams have jpeg frames!

Any hints ?
Hartmut

 

TinyPortal © 2005-2018