Forum > Options

Answer to Question: How to use CHM help?

(1/5) > >>

I see many people have problems to configure lazarus chm-help system. Here is the way how i solved it!


This  is modified version from readme.txt:
1 ) Start Lazarus

2 ) Install Packages:

In the Components Menu choose "Open Package File"

Don't click compile or install

With the lhelpcontrolpkg package still open, in the Components Menu choose "Open Package File".

3 ) Now click "Install" on "chmhelppkg.lpk" this will automatically install the first package we opened.

4 ) Restart Lazarus(if it didn't automatically)

5 ) Open the lhelp project in lazarus/components/chmhelp/lhelp/lhelp.lpi
    Compile lhelp-programm.
(Don't forget:
lazarus\fpc\2.3.1\bin\i386-win32\strip.exe lazarus/components/chmhelp/lhelp/lhelp.exe
for smaller exe-size)

6 ) Configure the paths for the lhelp:

    From the Help menu choose "Configure Help"
    Change to the "Viewers" tab and select "CHM Help Viewer"
    in latest Lazarus version:
    Environment->Options->Help->Help Options

    For the "HelpEXE" entry browse to the lazarus/components/chmhelp/lhelp/ folder
    and select the lhelp executable. i.e.:

    This is the directory that contains the lcl.chm fcl.chm and rtl.chm files.
     (don't forget last '\' , when you forget it, chm-file will be not opened frrom lhelp.exe!)

    HelpLabel Name and Tag do not need to be altered.

7 ) Configure the DataBases

    Choose the DataBases tab.

    this should be "rtl.chm://"
    this should be "fcl.chm://"
    this should be "lcl.chm://"

    NOTE if you have only a single lcl-fcl-rtl.chm file then then paths become:

Now close this window and check out the integrated help :)
Maybe you must change lazarus-paths for your system or OS.

Here some screenshots from my working help system:
Configuration and use demo.

Edit: My Lazarus system is:
Lazarus Version 0.9.29 Beta (2009-11-19)
FPC-Version 2.3.1
SVN-Revision: 22679

The packages chmhelppkg.lpk and lhelpcontrolpkg.lpk must be installed.
Look my 3. post below

Don't open lcl.chm, rtl.chm, fcl.chm outside the IDE. LHelp can not open this files if they opened.
There are not help for reserved pascal words (unit, interface, .....). Maybe i will solve this problem.

It didn't work for me with win32 laz 9.29 fpc 2.3.1 . Anyway anything this convoluted to install is not likely to be that reliable in any case. And probably will crash future releases since few will be aware of such an arcane install process. This help needs help.

The instruccions above are included in lazarus.

We have same Lazarus version. Don't forget to download chm-files and correct paths!
Try to compile lhelp program first (c:\lazarus\components\chmhelp\lhelp\lhelp.lpi)

I think first screenshot is enough help for configuration.

What don't work fo you?
Compiling of packages, programs or lhelp.exe don't load any chm-file?

As the helpsystem has never worked for me I was glad to see someone had a new solution.
Unfortunately this solution doesn't work for me, in step 5 compilation of lhelp.lpi ends with errors:

lhelpcore.pas(379,16) Error: identifier not found: srUnknown
lhelpcore.pas(379,25) Error: Identifier not found "srUnknown"
lhelpcore.pas(385,31) Error: Identifier not found "srInvalidFile"
lhelpcore.pas(392,31) Error: Identifier not found "srInvalidFile"
lhelpcore.pas(402,31) Error: Identifier not found "srSuccess"
lhelpcore.pas(405,35) Error: Identifier not found "srInvalidFile"
lhelpcore.pas(421,27) Error: Identifier not found "srSuccess"
lhelpcore.pas(424,31) Error: Identifier not found "srInvalidFile"
lhelpcore.pas(480) Fatal: There were 7 errors compiling module, stopping

Anyone any idea where those sr.... variables can be found?


My error is a lazarus feature as of late namely it is External sigsegv . Now I always get sigsegv when I hit run but many times it will run after that if I close the assembler window and hit run again. With lhelp i get a second external sigsegv error. ihelp compiled without error but that means nothing since 26.2 fpc 2.2.4. Assuming a version might work at some future time where does the ihelp icon go does it go into the IDE help menu? I still have online help.


[0] Message Index

[#] Next page

Go to full version