Recent

Author Topic: Lazarus crashes on Ubuntu 9.10, KDE4, when executing OpenDialog  (Read 22300 times)

giantics

  • Newbie
  • Posts: 4
Lazarus crashes on Ubuntu 9.10, KDE4, when executing OpenDialog
« on: October 31, 2009, 04:32:29 pm »
Hello,

since my update to Ubuntu 9.10 I have the problem, that Lazarus and any application created with Lazarus (0.9.28) crashes, when a OpenDialog is executed (or when clicking on a directory in this dialog). It seems this only happens when the KDE4 GTK-Style is set to QtCurve.

Can you affirm this?
Is this a bug in Lazarus or in QtCurve (other GTK-applications seem to run properly)?

funkybeast

  • Newbie
  • Posts: 3
Re: Lazarus crashes on Ubuntu 9.10, KDE4, when executing OpenDialog
« Reply #1 on: November 02, 2009, 06:13:18 am »
Happens to me too.

QtCurve is the problem. I've since changed to other themes and everything works fine
thereafter.

HTH,
Funky Beast

alter

  • Full Member
  • ***
  • Posts: 151
    • KSP website
Re: Lazarus crashes on Ubuntu 9.10, KDE4, when executing OpenDialog
« Reply #2 on: November 06, 2009, 02:06:14 am »
What Qt version? I use KDE 4.3 (Qt 4.5) and there are no problems with that. Distribution openSUSE 11.1

giantics

  • Newbie
  • Posts: 4
Re: Lazarus crashes on Ubuntu 9.10, KDE4, when executing OpenDialog
« Reply #3 on: November 12, 2009, 07:10:14 pm »
What Qt version? I use KDE 4.3 (Qt 4.5) and there are no problems with that. Distribution openSUSE 11.1

The problem appears on Kubuntu 9.10 (Qt 4.5). However it exists here on only one of my 2 computers (both have the same OS installed).

CML

  • New member
  • *
  • Posts: 5
Re: Lazarus crashes on Ubuntu 9.10, KDE4, when executing OpenDialog
« Reply #4 on: November 20, 2009, 09:39:58 am »
Confirm for Kubuntu 9.10 live or updated from 9.04 'alternate' CD: All programs compiled in Lazarus and using dialog for finding a file for *reading* crashes. Not for writing! And not for reading from file *without* dialog. The only way is 'sudo <name>'.
 Pure installation from DVD works OK for me.

CML

  • New member
  • *
  • Posts: 5
Re: Lazarus crashes on Ubuntu 9.10, KDE4, when executing OpenDialog
« Reply #5 on: November 20, 2009, 11:30:04 am »
May be solution: change Widget style from 'QtCurve' to 'Raleigh'.
( Appearence -> GTK+Appearence -> Widget style )

Saverio

  • New member
  • *
  • Posts: 8
Re: Lazarus crashes on Ubuntu 9.10, KDE4, when executing OpenDialog
« Reply #6 on: November 20, 2009, 04:59:06 pm »
Hi
 
The same behavior in Ubuntu 9.10. Lazarus crashes and every application compiled with Widget Type gtk2 as well.
« Last Edit: November 20, 2009, 08:51:09 pm by Saverio »

RJAndringa

  • Newbie
  • Posts: 2
Re: Lazarus crashes on Ubuntu 9.10, KDE4, when executing OpenDialog
« Reply #7 on: November 25, 2009, 07:22:23 pm »
I got the same on opensuse 11.2.
KDE 4.3.3 and Qt 4.5
messages:
TApplication.HandleException Invalid floating point operation                                                                       
  Stack trace:                                                                                                                     
  $00007FF574BF1428                                                                                                                 
  $00007FF574C03C83                                                                                                                 
  $00007FF574C0D927                                                                                                                 
  $00007FF57A645D3B                                                                                                                 
TApplication.HandleException: there was another exception during showing the first exception                                       
  Stack trace:                                                                                                                   
  $0000000000777987                                                                                                                 
  $0000000000991121                                                                                                                 
  $0000000000996E4C                                                                                                                 
  $0000000000996C76                                                                                                                 
  $0000000000A26091                                                                                                                 
  $0000000000927130                                                                                                                 
  $0000000000935415                                                                                                                 
  $0000000000793A25                                                                                                                 
  $00000000009223D3
  $0000000000924F97
  $00000000009353A6
  $000000000078DF70
  $000000000078ED1C
  $0000000000A097C7
  $0000000000777381
  $000000000082D363
  $0000000000881E62
[TMainIDE.Destroy] A
[TMainIDE.Destroy] B  -> inherited Destroy... TMainIDE
[TMainIDE.Destroy] END
[TGtkWidgetSet.Destroy] WAARSCHUWING: Er zijn nog 14 GDIObject niet vrijgegeven, een gedetailleerde dump volgt:
[TGtkWidgetSet.Destroy]   GDIOs: 00007FF5737F24A0 00007FF573806020 00007FF5738072A0 00007FF573806FA0 00007FF5738060A0 00007FF573807220 00007FF573806F20
[TGtkWidgetSet.Destroy]   gdiBitmap: 14

Troodon

  • Sr. Member
  • ****
  • Posts: 484
Re: Lazarus crashes on Ubuntu 9.10, KDE4, when executing OpenDialog
« Reply #8 on: November 25, 2009, 08:14:58 pm »
Everything works as expected on Ubuntu 9.10 with Lazarus 0.9.28.2-0 + FPC 2.2.4 and the gtk2 widgetset. Just don't run your application in the IDE; launch it using the file browser (Nautilus).
« Last Edit: November 26, 2009, 04:34:05 am by Troodon »
Lazarus/FPC on Linux

Huxlay

  • Newbie
  • Posts: 1
Re: Lazarus crashes on Ubuntu 9.10, KDE4, when executing OpenDialog
« Reply #9 on: July 29, 2010, 08:53:06 am »
I m agree with the point that the same behavior in Ubuntu 9.10. Lazarus crashes and every application compiled with Widget Type gtk2 as well.
Huxlay

michaelthuma

  • New member
  • *
  • Posts: 46
Re: Lazarus crashes on Ubuntu 9.10, KDE4, when executing OpenDialog
« Reply #10 on: September 15, 2010, 09:31:28 am »
I cannot remember exactly you must set a property ... sry I cannot remember, but does it come when you filter for specific file extensions?

michaelthuma

  • New member
  • *
  • Posts: 46
Re: Lazarus crashes on Ubuntu 9.10, KDE4, when executing OpenDialog
« Reply #11 on: September 15, 2010, 09:32:35 am »
I think it is in case that no file was selected. Is this possible?

acoliveira

  • Newbie
  • Posts: 3
Re: Lazarus crashes on Ubuntu 9.10, KDE4, when executing OpenDialog
« Reply #12 on: October 19, 2010, 07:43:57 pm »
sorry for my poor english,... [ 8) ]
I have problem too, but not executing OpenDialog, this problem is related with xsystem/x11, i changed kubuntu for debian and application run very well.

KelseyPedroza

  • Newbie
  • Posts: 1
Re: Lazarus crashes on Ubuntu 9.10, KDE4, when executing OpenDialog
« Reply #13 on: March 15, 2011, 01:15:39 pm »
Hello,

since my update to Ubuntu 9.10 I have the problem, that Lazarus and any application created with Lazarus (0.9.28) crashes, when a OpenDialog is executed (or when clicking on a directory in this dialog). It seems that this site on the wealthy affiliate has a lot of nice reviews and this only happens when the KDE4 GTK-Style is set to QtCurve.

Can you affirm this?
Is this a bug in Lazarus or in QtCurve (other GTK-applications seem to run properly)?

I am having problem with with the latest Ubuntu 10.10 notebook edition that Lazarus crashes.
Whats should i do?
« Last Edit: September 21, 2016, 03:07:01 pm by KelseyPedroza »

zeljko

  • Hero Member
  • *****
  • Posts: 1050
    • http://wiki.lazarus.freepascal.org/User:Zeljan
Re: Lazarus crashes on Ubuntu 9.10, KDE4, when executing OpenDialog
« Reply #14 on: March 15, 2011, 03:04:32 pm »
Hey.
I am having problem with with the latest Ubuntu 10.10 notebook edition that Lazarus crashes.
Whats should i do????

If you use qt lazarus on ubuntu/kubuntu which is >= qt-4.7.XX bases then libQt4Pas from ubuntu repo isn't good. Bindings must be compiled with -mstackrealing to avoid such crashes.
So, you can download binary bindings of libQt4Pas from official page (they are marked as "Qt-4.7 compatibile")