Recent

Author Topic: Problems with TPqSQL component - It doesn´t work :(  (Read 6919 times)

marcelo_jr

  • Newbie
  • Posts: 2
Problems with TPqSQL component - It doesn´t work :(
« on: May 03, 2005, 10:20:44 pm »
Hello people,

 I'm having problems with PostgreSQL and Lazarus. I have installed the packages SQLDBLAZ and PQCONNECTIONLAZ which are encountered in
/usr/share/lazarus/components/sqldb (I´m using Fedora Core2 Operating System).  Both of these packages were installed successfully.

  However, when I try to connect to a database using the component TPqConnection, a messagebox is showed containing the following message: "Can not load Postgresql client. Is it installed (libpq.so) ?" .

Does anybody in the community know how to solve this
problem ??????   Please, help me because I must advocate the use of
FreePascal instead of Java in some areas of my enterprise. I work in one of the biggest software companies of latin america and it should be an honor to me introduce Lazarus in Here. I'm trying to develop a Linux version of my Optical inventory system which was written in Delphi 7.0 and it works perfectly well.

 Thank you in advance,

Marcelo Ramos de Oliveira Júnior
SERPRO - Brazillian Federal Service of Data Processing

hombergs

  • New Member
  • *
  • Posts: 15
Problems with TPqSQL component - It doesn´t work :(
« Reply #1 on: May 04, 2005, 04:10:54 am »
Did you use PostgreSQL 7.x or 8.x?
Did the symlink /usr/bin/libpg.so exist?

Maybe you can try Zeos.
In this Posting Stevie (he is a Zeosteam member) anounced that the porting of Zeos to Lazarus is finished.
You should use for Zeos the actual FPC and Lazarus CVS.
With Zeos you can access Interbase, Firebird, MySQL, PostgreSQL and SQLite in an easy way.
Zeos Teammember

hombergs

  • New Member
  • *
  • Posts: 15
Problems with TPqSQL component - It doesn´t work :(
« Reply #2 on: May 04, 2005, 04:13:28 am »
Uuups,
sry. I mean  /usr/lib/libpg.so and not  /usr/bin/libpg.so ;)
Zeos Teammember

 

TinyPortal © 2005-2018