Recent

Author Topic: KSP 2009 R2.2  (Read 8590 times)

alter

  • Full Member
  • ***
  • Posts: 151
    • KSP website
KSP 2009 R2.2
« on: September 22, 2009, 02:35:06 pm »
I wish to present new KSP version! KSP is an audio player designed for Windows and Linux. It provides functionality like:

    * Media Library support
    * MP3, WMA and OGG support (more types soon)
    * M3U and PLS playlists support
    * Plugins support
    * Bookmarks support
    * Icecast/shoutcast support
    * and more...

KSP requires 40  MB of HDD and can be installed on Windows XP or newer. KSP also supports Linux based systems (see download section). Note that in those 40 MB there are included all required 3rd party libraries including QT

Some screenshots - http://ksplayer.boo.pl/screenshots
Current todo list - http://ksplayer.boo.pl/ksp-project-status

Note: if you want to help KSP visit http://ksplayer.boo.pl/help-wanted for more details.

hinst

  • Sr. Member
  • ****
  • Posts: 303
Re: KSP 2009 R2.2
« Reply #1 on: September 23, 2009, 01:28:35 pm »
40 megabytes?? O.M.G   :o
Too late to escape fate

alter

  • Full Member
  • ***
  • Posts: 151
    • KSP website
Re: KSP 2009 R2.2
« Reply #2 on: September 23, 2009, 02:07:12 pm »
Don't worry, Next release will be around 18 MB (beta of it is actually 17.5). It's simply that with releases so far we fixed on improving stability and functionality. Now since the most common bugs appear to be fixed (a least most of them) we can fix on reducing the size of KSP (that includes also optimising the code itself)

DenJean

  • New Member
  • *
  • Posts: 18
Re: KSP 2009 R2.2
« Reply #3 on: September 23, 2009, 03:59:59 pm »
included all required 3rd party libraries including QT
Browsing the ksp-2009-r3-alpha3-lin.tar.gz archive, I see a readme that provides instructions on how to upgrade lazarus trunk to use V1.72. I am sorry but it is a bit more complex than that. See http://lists.lazarus.freepascal.org/pipermail/qt/2009-September/001276.html. Your code in main.pas is V1.71 compatible (use of new QLCLWebPage_override_userAgentForUrl, old signal hooking way) in main.pas. So change V1.72 in V1.71 in your readme (also still available on web site)

alter

  • Full Member
  • ***
  • Posts: 151
    • KSP website
Re: KSP 2009 R2.2
« Reply #4 on: September 24, 2009, 05:20:07 pm »
I'm sorry for that. I guess I had to overlook that and of course, QT bindings required are 1.71 not 1.72. Compilation procedure (this time with correct bindings mentioned) can be found here: http://ksplayer.boo.pl/component/content/article/2-ksp-docs/17-ksp-compilation
Also this weekend there should be beta 1 available with basic lyrics support and equalizer. Prerelease source can be found already in trunk. This version is compiled with Lazarus 0.9.29 and fpc 2.2.4. Although Windows compilation may be broken (some changes to the code may be responsible for that and this is why there is no official beta 1 compilation yet)

 

TinyPortal © 2005-2018