Recent

Author Topic: New MySQL 5.1.37 compatible with the SQLdb  (Read 7783 times)

IndianaJones

  • Hero Member
  • *****
  • Posts: 509
New MySQL 5.1.37 compatible with the SQLdb
« on: August 12, 2009, 09:25:36 pm »

Hi all,

I have been testing new mysql 5.1 but get the following error.

Can not load default MySQL library ('libmysql.dll' or 'libmysql.dll'). Check your installation.

Thanks

IndianaJones

  • Hero Member
  • *****
  • Posts: 509
Re: New MySQL 5.1.37 compatible with the SQLdb
« Reply #1 on: August 13, 2009, 12:13:00 am »

Hi all,

I have tested MySQL version 5.1.30 and get the attached error.
Thanks.

FPC 2.3.1
Lazarus 0.9.27 svn 21164
Carbon

Marc

  • Administrator
  • Hero Member
  • *
  • Posts: 2496
Re: New MySQL 5.1.37 compatible with the SQLdb
« Reply #2 on: August 13, 2009, 11:37:27 am »
I fear you need a TMySql51Connection for this

The mysql team has a reputation of changing api between versions
//--
{$I stdsig.inc}
//-I still can't read someones mind
//-Bugs reported here will be forgotten. Use the bug tracker

IndianaJones

  • Hero Member
  • *****
  • Posts: 509
Re: New MySQL 5.1.37 compatible with the SQLdb
« Reply #3 on: August 13, 2009, 03:13:54 pm »

Thanks for the reply, anyway 5.0 is working. :)