Recent

Author Topic: Lazarus + QT4: What about license?  (Read 11106 times)

osvaldo-tcf

  • Jr. Member
  • **
  • Posts: 61
Lazarus + QT4: What about license?
« on: November 30, 2007, 06:31:40 pm »
Hi. If i use lazarus with qt4, what type of license my application has ?

I have to paid for trolltec ?

Almindor

  • Sr. Member
  • ****
  • Posts: 412
    • http://www.astarot.tk
RE: Lazarus + QT4: What about license?
« Reply #1 on: December 01, 2007, 01:37:41 pm »
Yes if you use it for commercial use. Otherwise you are GPL AFAIK. All QT4 restrictions apply.

Troodon

  • Sr. Member
  • ****
  • Posts: 484
RE: Lazarus + QT4: What about license?
« Reply #2 on: July 30, 2008, 08:21:30 pm »
GPL = you must give away the program source code, whether you charge for your software or not.
Lazarus/FPC on Linux

DenJean

  • New Member
  • *
  • Posts: 18
Re: Lazarus + QT4: What about license?
« Reply #3 on: May 28, 2009, 10:25:41 pm »
Hi. If i use lazarus with qt4, what type of license my application has ?

I have to paid for trolltec ?

Updated: No. Qt is LGPL now:

http://www.qtsoftware.com/products/licensing/licensing#qt-gnu-lgpl-v

Qt GNU LGPL v. 2.1 Version

This version is available for development of proprietary and commercial applications in accordance with the terms and conditions of the GNU Lesser General Public License version 2.1


Troodon

  • Sr. Member
  • ****
  • Posts: 484
Re: Lazarus + QT4: What about license?
« Reply #4 on: May 29, 2009, 12:41:52 am »
I have installed the Qt-4.5 SDK on Ubuntu Hardy. So far so good, except that the system continues to use the distro Qt release, i.e. 4.3 (could not uninstall it, otherwise too many dependencies would have been broken). So now I need to figure out a way to build my Lazarus/FPC apps using the 4.5 lib in the SDK. ::scratches head::
Lazarus/FPC on Linux

Paul Ishenin

  • Sr. Member
  • ****
  • Posts: 274
Re: Lazarus + QT4: What about license?
« Reply #5 on: May 29, 2009, 08:09:55 am »
to build lazarus itself you can run "make clean bigide LCL_PLATFORM=qt OPT=-dUSE_QT_45"

Troodon

  • Sr. Member
  • ****
  • Posts: 484
Re: Lazarus + QT4: What about license?
« Reply #6 on: May 29, 2009, 04:37:22 pm »
to build lazarus itself you can run "make clean bigide LCL_PLATFORM=qt OPT=-dUSE_QT_45"

Thanks, Paul. Actually, I was thinking of re-building only the LCL with packages and then setting the compiler options to Qt for my Lazarus/FPC application. Problem is, I haven't figured out yet how to link against a Qt library version that is not the default version on my Ubuntu system (in this case, Qt-4.5 brought by the SDK installed under /opt).

Anyway, there are probably few systems that come with Qt-4.5 preinstalled at this time, so I guess I'll have to wait a while before Qt-4.5 apps can run anywhere.
Lazarus/FPC on Linux

Troodon

  • Sr. Member
  • ****
  • Posts: 484
Re: Lazarus + QT4: What about license?
« Reply #7 on: June 04, 2009, 07:07:14 pm »
I am trying to build an app under Windows XP using the Qt-4.5 widget set (QtCore4.dll and QtGui4.dll, release 4.5.0, are in the same directory as my executable). I installed libqt4intf.dll in C:\Windows\System32 and qt4.pas in FPC\Lazarus\lcl\interfaces\qt (v1.70, as per http://users.telenet.be/Jan.Van.hijfte/qtforfpc/fpcqt4.html). I set LCL Widget Type = qt (beta) in Compiler Options and also Project|Compiler|Options|Other|Custom options = -dUSE_QT_45. I successfully built the executable.

Upon launching the application I get the error message shown in the attachment. Any sugestions?
« Last Edit: June 04, 2009, 07:27:53 pm by Troodon »
Lazarus/FPC on Linux

Zaher

  • Hero Member
  • *****
  • Posts: 593
    • parmaja.com
Re: Lazarus + QT4: What about license?
« Reply #8 on: June 21, 2009, 04:02:18 pm »
That error when you install qt the SDK , but when install
"Download Qt libraries 4.5 for Windows"
It work fine with me.

 

TinyPortal © 2005-2018