Recent

Author Topic: Lazarus 3.4  (Read 1240 times)

zlib

  • Newbie
  • Posts: 1
Lazarus 3.4
« on: June 15, 2024, 02:18:09 am »
I have MacBook Pro on Apple Silicon under macOS Sonoma 14.5 and I have installed Lazarus from here (all 3 packages): https://sourceforge.net/projects/lazarus/files/Lazarus%20macOS%20x86-64/Lazarus%203.4/

Xcode tools were already installed.

Lazarus starts normally, but when I try to run any project I get 1 warning and 1 error:

Code: Text  [Select][+][-]
  1. Warning: ld: warning: -multiply_defined is obsolete
  2. Error: -macosx_version_min has been renamed to -macos_version_min

'About' screen says I have x86_64 version.
What should I do?

dbannon

  • Hero Member
  • *****
  • Posts: 2902
    • tomboy-ng, a rewrite of the classic Tomboy
Lazarus 3, Linux (and reluctantly Win10/11, OSX Monterey)
My Project - https://github.com/tomboy-notes/tomboy-ng and my github - https://github.com/davidbannon

 

TinyPortal © 2005-2018