Forum > Editor

[SOLVED] Source editor (2)

(1/1)

CM630:
I have all dockings in the IDE installed.
When I open some projects, instead of having the project open in th emain form, I get a second main form, titled „Source editor (2)“.
Any idea how to have these projects open normally in a single window?

Martin_fr:
Dock the 2nd SourceEditor? SCNR.

Ok, what you have is a 2nd Window (can be docked) containing sources. In an undocked IDE, you can have as many of them as you want and position them side by side, so you can see several files at once. Or even one and the same file, but several times (scrolled differently).

If you wanted, then in AnchorDocking you can dock them side by side too.

If you don't want them side by side, then just drag the editor tab (not the anchor docking tab, but the editor tab, with the source file name) into the tabs of your existing source-editor.  (You can probably just close all tabs in that 2nd editor window, and then they should reopen in the first, if you reopen them / though there are various settings ...)


As to how you may have gotten them...

There are menu entries in the editor tabs context menu.
There are key combos.

Once you had an editor in a 2nd (or 3rd) window, the IDE remembers for that project. So it will restore this, if you reopen the project. If you however close them, and then make sure the project session is saved, then the info should be gone....
Well the IDE would still know, where the unit was last opened.... (That is why you may have to move the tabs back).

For opening units, there are settings in "Pages and Windows" of the editor options.

CM630:
Moving and dragging the window did not help.
But following your explanation, I opened Main menu — Project — Project options — Session.
Save session information in was set to Save in .lpi file. I changed it to Save in .lps file in the project directory, then I deleted the .lps file.
Now it works fine.

Navigation

[0] Message Index

Go to full version