Forum > macOS / Mac OS X

unversioned libcrypto dylib

(1/1)

Michael Collier:
Hi

I used online package manger to install lazmapviewer which in turn installed synapse (I think).

I rebuilt the IDE, but now it won't open, unversioned libcrypto dylib

I found this link in forum but not sure how to go about fixing (I'm not an apple person) https://wiki.lazarus.freepascal.org/macOS_Programming_Tips#OpenSSL.2C_LibreSSL.2C_Secure_Transport.2C_Network_Framework

My lazarus version is 2.2.0 and fpc is 3.2.2

Apple is macOS Monterey V12.6.2

This is the first time Lazarus has failed to open for me, so not sure what to do, and can't uninstall packages without IDE.

Do I need to upgrade my apple computer, if so how, I found links to answers where users use (brew?) and then copy files manually?

Thanks,Mike

dseligo:

--- Quote from: Michael Collier on June 06, 2024, 12:14:37 am ---This is the first time Lazarus has failed to open for me, so not sure what to do, and can't uninstall packages without IDE.

--- End quote ---

Not sure about macOS, but under Windows Lazarus creates 'lazarus.old' file. You need to replace 'lazarus' with 'lazarus.old' and you will have last one that worked.

Michael Collier:
I tried the rename trick when it first crashed, it did allow lazarus to open but the menu seemed different, couldn't see a'packages' item. I rebuilt using fpcupdeluxe and have lost lazarus.old so can't retry

Navigation

[0] Message Index

Go to full version