Recent

Author Topic: The debugger does not display variable values ​​correctly.  (Read 1037 times)

Seenkao

  • Hero Member
  • *****
  • Posts: 558
    • New ZenGL.
Linux, Debian 12.
FPC 3.2.2-r0d122c49 x86_64
Lazarus 3.2
FpDebug

Уже далеко не в первый раз отладчик не показывает значения переменных. Для их отображения мне приходится использовать логи.
Сложные данные могут правильно отображаться, а отдельные переменные могут либо не отображаться, либо отображаться не правильно.

Возможно это связано с тем, что в функции/процедуре задано много временных переменных. Но это не точно, по моему раньше были проблемы и в то время, когда переменных было мало.

Код выложить не могу, так как кода много. Вариант проверки: использовать ZenGL в модуле zgl_text процедура text_CalcRect. При попытке отладки, переменные просто "пляшут". Если делать логи, то можно узнать корректные значения переменных.


-----------------------------------------
Google translate:
This is not the first time that the debugger does not show the values ​​of variables. I have to use logs to display them.
Complex data may be displayed correctly, but individual variables may not be displayed or displayed incorrectly.

This may be due to the fact that many temporary variables are specified in the function/procedure. But this is not certain, in my opinion there were problems before at a time when there were few variables.

Verification option: use ZenGL in the module zgl_text procedure text_CalcRect. When trying to debug, the variables just "dance". If you make logs, you can find out the correct values ​​of the variables.
Rus: Стремлюсь к созданию минимальных и достаточно быстрых приложений.

Eng: I strive to create applications that are minimal and reasonably fast.
Working on ZenGL

Martin_fr

  • Administrator
  • Hero Member
  • *
  • Posts: 10013
  • Debugger - SynEdit - and more
    • wiki
Re: The debugger does not display variable values ​​correctly.
« Reply #1 on: June 03, 2024, 09:34:38 am »
I can see (most of)  your demos are -O3
Do you use that for debugging too?

Debugging only works with -O- or -O1
Strongly recommended -O-
-O1 can still have occasional wrong values (delayed updates).

Seenkao

  • Hero Member
  • *****
  • Posts: 558
    • New ZenGL.
Re: The debugger does not display variable values ​​correctly.
« Reply #2 on: June 03, 2024, 01:14:13 pm »
Martin_fr, thanks!
Google translate:
Yes, this is apparently my problem, I forget to switch Debug/Release modes. This means I have more work to do on correcting the demos...


Да это видимо моя проблема, забываю переключать режимы Debug/Release. Значит мне ещё добавилось работы по корректировке демок...
Rus: Стремлюсь к созданию минимальных и достаточно быстрых приложений.

Eng: I strive to create applications that are minimal and reasonably fast.
Working on ZenGL

 

TinyPortal © 2005-2018