Recent

Author Topic: Problem with cross-compiling for arm (armv6, armv7)  (Read 211 times)

svd71

  • New Member
  • *
  • Posts: 32
Problem with cross-compiling for arm (armv6, armv7)
« on: May 26, 2024, 04:34:26 pm »
Hallo all,

I have Lazarus 3.2 and fpc 3.2.2 on the board. thes things are installed with fpcupdelux under Windows 10.

If I do little project for test with only one 'writeln('start');' in code, it works for "Target CPU family" "aarch64".
The command
Code: Bash  [Select][+][-]
  1. $>ldd ./project1
shows many depended libraries and application run without problem.

But if I set up the "Target CPU family" as "arm", does not meter "Target processor" (I had tried to do with armv6*, armv7*, Default and soon) - the application run with message:
Code: Bash  [Select][+][-]
  1. bash: ./project1: cannot execute: required file not found


the command ldd shows:
Code: Bash  [Select][+][-]
  1. not a dynamic executable
 

Can somebody check it?
and how can I fix it?

What about compilation for "Raspberry Pi Zero W" version 1.1 with "armv6l"?

 

TinyPortal © 2005-2018