Recent

Author Topic: [SOLVED] LAMW/Linux - Installation error: can't compile lazandroidwizardpack.lpk  (Read 590 times)

Alcatiz

  • New member
  • *
  • Posts: 9
Hi all!

I'm trying to install the latest version of LAMW from scratch on a Debian 11 (64 bits), using lamw_manager. Everything goes right except when compiling lazandroidwizardpack.lpk. I first got an error "Identifier not found: FpChMod" in createfiles.pas, which I could correct, but now I'm getting more and more compile errors in ostypes.inc, a.s.o, so I stop trying to solve it by myself.

Am I the only one to encounter installation errors?

Thx
« Last Edit: April 22, 2024, 08:06:34 pm by Alcatiz »

jmpessoa

  • Hero Member
  • *****
  • Posts: 2304
Quote
"Identifier not found: FpChMod" in createfiles.pas, which I could correct.....

How do you correct/fix  it?

My "createfiles.pas" Fix:
Code: Pascal  [Select][+][-]
  1. uses
  2.   {$ifdef unix}BaseUnix,{$endif}     //  <--- Fixed !
  3.   Classes,
  4.   SysUtils;  
  5.   ...
  6.  
« Last Edit: April 21, 2024, 08:59:04 pm by jmpessoa »
Lamw: Lazarus Android Module Wizard
https://github.com/jmpessoa/lazandroidmodulewizard

Alcatiz

  • New member
  • *
  • Posts: 9
Hi jmpessoa!

You're right, this directive corrects the problem!  8-)  :)

Many many many thanks!

[Edit]lamw_manager reports an error: "please wait, saving LAMW4Linux config .../home/alcatiz/Téléchargements/LAMWManager-linux-base-state/lamw_manager/core/settings-editor/lamw-settings-editor.sh: ligne 183: update-desktop-database : unknown command"[/Edit]
« Last Edit: April 22, 2024, 09:57:53 pm by Alcatiz »

 

TinyPortal © 2005-2018