Forum > Networking and Web Programming

Who is Indy mattias?

(1/2) > >>

I have just installed first the OnlinePackageManager and then from there I installed indylaz. I added it as a requirement to my project and tried to compile a program that worked before I totally reinstalled Lazarus. Now I get many errors, like

Error: /home/mattias/tmp/lazarus-project3.0.0/lazarus-project-build/usr/share/lazarus/3.0.0/lcl/comctrls.pp... and specific details.
and a lot of Liner warnings.

Is it possible that in the package the developer's folder remained as a hard coded name, or I do something wrong?

What is the exact error message?
Mattias Gärtner has built the release packages of Lazarus for Linux and MacOS. His home path must be left somewhere although I don't know how it can affect the compilation of your project.

The error messages are as said above. I made a screenshot of the first errors:

What I also tried is another project that compiles just OK (and does not use any networking, indy or other). Then I add in the Project Inspector the freshly downloaded indylaz to the Required Packages (no unit mentioned explicitly) and I get the 73 error pairs like the ones on the screenshot and obviously a 74th error "Error while linking". If I remove it as a required package then my project (the one without networking) compiles again.
In my networking project, I cannot remove the required package because then the units are not found.

Add the Interfaces unit to uses section

Thanks, it is like magic. It works.

However, I still do not understand:
- How mattias is hardcoded in so many places?
- How could it work in the past with - I guess the same - Indy10 without adding Interfaces?
What is Interfaces, anyway? Why I never met it before?



[0] Message Index

[#] Next page

Go to full version