Recent

Author Topic: lazarus-project_3.2.0-0_amd64.deb - dependency problems [SOLVED]  (Read 938 times)

midigark

  • Newbie
  • Posts: 1
Hmm,
On Linux Mint 21.3 newly installed on recently built system.
So, in my case, it has nothing to do with it being an older version of Linux Mint.

gdebi - get the Dependencies not satisfiable error
dpkg - dependency problems, leaving unconfigured...

But, dpkg did give clues as to what was missing:

Selecting previously unselected package lazarus-project.
(Reading database ... 631231 files and directories currently installed.)
Preparing to unpack lazarus-project_3.2.0-0_amd64.deb ...
Unpacking lazarus-project (3.2.0) ...
dpkg: dependency problems prevent configuration of lazarus-project:
 lazarus-project depends on libgtk2.0-dev (>= 2.6.0); however:
  Package libgtk2.0-dev is not installed.
 lazarus-project depends on fpc-laz (= 3.2.2); however:
  Package fpc-laz is not installed.
 lazarus-project depends on fpc-src (= 3.2.2); however:
  Package fpc-src is not installed.

dpkg: error processing package lazarus-project (--install):
 dependency problems - leaving unconfigured
Processing triggers for gnome-menus (3.36.0-1ubuntu3) ...
Processing triggers for desktop-file-utils (0.26+mint3+victoria) ...
Processing triggers for mailcap (3.70+nmu1ubuntu1) ...
Processing triggers for shared-mime-info (2.1-2) ...
Processing triggers for man-db (2.10.2-1) ...
Errors were encountered while processing:
 lazarus-project
=
So I will install those and try again.
Mark

edit: that fixed it
« Last Edit: April 17, 2024, 06:29:07 pm by midigark »

dbannon

  • Hero Member
  • *****
  • Posts: 2854
    • tomboy-ng, a rewrite of the classic Tomboy
Re: lazarus-project_3.2.0-0_amd64.deb - dependency problems [SOLVED]
« Reply #1 on: April 18, 2024, 01:46:43 pm »
As a matter of interest midigark, did you install fpc-laz_3.2.2-210709_amd64.deb and fpc-src_3.2.2-210709_amd64.deb first or, at least simultaneously with the lazarus-project_3.2.0-0_amd64.deb package ?

As per the instructions -

Code: [Select]
sudo apt install ./fpc_something.deb ./fpc-src_something.deb ./lazarus-something.deb
I ask because what you show sure looks like you tried to install just lazarus-project_3.2.0-0_amd64.deb

Opening the lazarus package with (the GUI) gdebi before you have installed fpc and fpc-src will most certainly fail. dpkg too does not resolve dependencies. Thats why the instructions say use apt.

Davo
Lazarus 3, Linux (and reluctantly Win10/11, OSX Monterey)
My Project - https://github.com/tomboy-notes/tomboy-ng and my github - https://github.com/davidbannon

Edgardo M. López

  • New Member
  • *
  • Posts: 12
Re: lazarus-project_3.2.0-0_amd64.deb - dependency problems [SOLVED]
« Reply #2 on: April 18, 2024, 02:29:07 pm »
Hello..
I'll give you the link to a video on YouTube on how to install it on Ubuntu 22.04. The method is the same for Linux Mint. I'm sure it can help you

https://www.youtube.com/watch?v=HrcTVG1CW9I

 

TinyPortal © 2005-2018