Forum > macOS / Mac OS X

Lazarus project made on Mac OS 12.5.1 crash on MAC OS 10.7.5 [SOLVED]

(1/1)

Odacir:
Hi,

I need compile a project in lazarus, to run in older 10.7.5 system. On the Monterey (12.5.1) all ok, but on 10.7.5 crash on start.

I tested a simple project without nothing, and the same crash.

Have some compile option to support old system, or something to-do to run on older system?


The details of the report of crash is:


--- Code: Pascal  [+][-]window.onload = function(){var x1 = document.getElementById("main_content_section"); if (x1) { var x = document.getElementsByClassName("geshi");for (var i = 0; i < x.length; i++) { x[i].style.maxHeight='none'; x[i].style.height = Math.min(x[i].clientHeight+15,306)+'px'; x[i].style.resize = "vertical";}};} ---Process:         launchd [68384]Path:            /Users/USER/Documents/*/test_path.app/Contents/MacOS/test_pathIdentifier:      com.company.test_pathVersion:         ??? (???)Code Type:       X86-64 (Native)Parent Process:  launchd [379] Date/Time:       2024-04-16 13:54:00.937 -0300OS Version:      Mac OS X 10.7.5 (11G63)Report Version:  9 Interval Since Last Report:          34948118 secCrashes Since Last Report:           50711Per-App Crashes Since Last Report:   9Anonymous UUID:                      6E8BCDDD-A4E0-4A73-9329-57670CD815D1 Crashed Thread:  Unknown Exception Type:  EXC_BAD_ACCESS (SIGSEGV)Exception Codes: KERN_INVALID_ADDRESS at 0x00007fff5fc01028 Backtrace not available Unknown thread crashed with X86 Thread State (64-bit):  rax: 0x0000000000000055  rbx: 0x0000000000000000  rcx: 0x0000000000000000  rdx: 0x0000000000000000  rdi: 0x0000000000000000  rsi: 0x0000000000000000  rbp: 0x0000000000000000  rsp: 0x0000000000000000   r8: 0x0000000000000000   r9: 0x0000000000000000  r10: 0x0000000000000000  r11: 0x0000000000000000  r12: 0x0000000000000000  r13: 0x0000000000000000  r14: 0x0000000000000000  r15: 0x0000000000000000  rip: 0x00007fff5fc01028  rfl: 0x0000000000010203  cr2: 0x00007fff5fc01028Logical CPU: 2 Binary images description not available  External Modification Summary:  Calls made by other processes targeting this process:    task_for_pid: 1    thread_create: 0    thread_set_state: 0  Calls made by this process:    task_for_pid: 0    thread_create: 0    thread_set_state: 0  Calls made by all processes on this machine:    task_for_pid: 20394575    thread_create: 0    thread_set_state: 0 Model: iMac12,1, BootROM IM121.0047.B1F, 4 processors, Intel Core i5, 2.5 GHz, 8 GB, SMC 1.71f22Graphics: AMD Radeon HD 6750M, AMD Radeon HD 6750M, PCIe, 512 MBMemory Module: BANK 0/DIMM0, 4 GB, DDR3, 1333 MHz, 0x0000, 0x484233535530303447464D384D4D44333320Memory Module: BANK 1/DIMM0, 4 GB, DDR3, 1333 MHz, 0x80AD, 0x484D5434353153364D465238432D50422020AirPort: spairport_wireless_card_type_airport_extreme (0x168C, 0x9A), Atheros 9380: 4.0.67.5-P2PBluetooth: Version 4.0.8f17, 2 service, 18 devices, 1 incoming serial portsNetwork Service: Ethernet, Ethernet, en0Serial ATA Device: ST3500418AS, 500,11 GBSerial ATA Device: Samsung SSD 850 EVO 1TB, 1 TBUSB Device: FaceTime HD Camera (Built-in), apple_vendor_id, 0x850b, 0xfa200000 / 3USB Device: hub_device, 0x0424  (SMSC), 0x2514, 0xfa100000 / 2USB Device: Dell USB Entry Keyboard, 0x413c  (Dell Inc.), 0x2107, 0xfa120000 / 5USB Device: BRCM2046 Hub, 0x0a5c  (Broadcom Corp.), 0x4500, 0xfa110000 / 4USB Device: Bluetooth USB Host Controller, apple_vendor_id, 0x8215, 0xfa111000 / 8USB Device: hub_device, 0x0424  (SMSC), 0x2514, 0xfd100000 / 2USB Device: USB Optical Mouse, 0x046d  (Logitech Inc.), 0xc077, 0xfd130000 / 5USB Device: Internal Memory Card Reader, apple_vendor_id, 0x8403, 0xfd110000 / 4USB Device: IR Receiver, apple_vendor_id, 0x8242, 0xfd120000 / 3 

Jonas Maebe:
You have to compile with the -WM10.7 command line option

Odacir:
You are the best Jonas!!! Solved!!! Thanks a lot!!!!

Navigation

[0] Message Index

Go to full version