Forum > Windows (32/64)

[solved] Lazarus does not start after installing a package

(1/2) > >>

Are there any known issues that prevent Lazarus from starting after installing a package that has no known issues?

Could it be an executable size problem? After installing BGRAcontrols, I get a LAZARUS.EXE that is 345 Mb, and that does not start. The previous executable, which is 323 Mb, works fine.

This problem has also happened to me after installing other packages, both with Lazarus 3.0 and Lazarus 3.2, and on two different PCs.

Windows 10 64 bit, Lazarus 32 bit.

Exe size should not be an issue.

One possibility might be a dll dependency. If any installed package requires a dll to be present (like maybe a database related package may need the db driver dll).
Mind that dll must be the correct bitness, for a 32 bit IDE you would need 32bit dll.

It could also be an issue with some of the packages, even if you say "no known issue"...
You still have lazarus.old.exe to recover?

Do check for problems you can:

The lazarus that does not work, run it from cmd.exe :
   lazarus.exe --debug-log=mylog.txt
Then check the logfile for errors.

When you rebuild your IDE with the package:
 => do not restart it.
 => in Tools >Configure build lazarus => add: -gw -gl
Open the project ide/lazarus.lpi
This will run the newly build IDE in the debugger.
You likely either get an "some error" message, or "exited with code ..."

Well, I tried  lazarus.exe --debug-log=mylog.txt and got this:

using config file D:\SPSLSD0002\Documents\varios\_soft\Lazarus\lazarus.cfg
[FORMS.PP] ExceptionOccurred
  Exception=Can not load SQLite client library "sqlite3.dll". Check your installation.
  Stack trace:
[FORMS.PP] ExceptionOccurred

Does Lazarus require sqlite3.dll to start?
Why didn't this error occur before installing BGRAbitmap (in my last test)?

You probably have a package in your install list that requires the dll.

That is, if you ever installed a package that requires it, then that will be noted in your config.
Until you actually go to menu Packages > Packages, and uninstall it, this package stays in the list of installed packages.

- If you uninstall Lazarus, the config remains on your PC
- If you install a new Lazarus, the config remains on your PC
   Though in the installer there is a checkbox to clean the config, so you can get rid of it.

After installing a new Lazarus, the installed package is pending. It is not compiled into you lazarus exe.
But as soon as you recompile the IDE for any reason (install any other package) the pending packages are being installed too.

Thanks Martin_fr, you were right, one of my packages required sqlite3.dll and it didn't find it. My package and my fault. I made some modifications to this package and now the IDE starts fine. Thank you so much.


[0] Message Index

[#] Next page

Go to full version