Recent

Author Topic: [SOLVED] not responding message at breakpoint  (Read 629 times)

petevick

  • Sr. Member
  • ****
  • Posts: 374
[SOLVED] not responding message at breakpoint
« on: May 03, 2024, 12:37:38 pm »
I keep getting the attached message in debug mode when I have a breakpoint set. Is there a way to permanently turn the it off, it's pretty meaningless  as I know it's not responding because of the breakpoint !!
« Last Edit: May 06, 2024, 11:56:11 am by petevick »
Pete Vickerstaff
Linux Mint 21.2 Cinnamon, Windows 10, Lazarus 3.2, FPC 3.2.2

Martin_fr

  • Administrator
  • Hero Member
  • *
  • Posts: 10010
  • Debugger - SynEdit - and more
    • wiki
Re: not responding message at breakpoint
« Reply #1 on: May 03, 2024, 01:00:49 pm »
This may or may not depend on your Linux distro/desktop.

I googled and found https://askubuntu.com/questions/1068921/how-to-disable-the-window-not-responding-dialog

petevick

  • Sr. Member
  • ****
  • Posts: 374
Re: not responding message at breakpoint
« Reply #2 on: May 03, 2024, 01:05:15 pm »
This may or may not depend on your Linux distro/desktop.

I googled and found https://askubuntu.com/questions/1068921/how-to-disable-the-window-not-responding-dialog
So it's not a Lazarus thing then, I just assumed it was  :o Thanks for the link Martin_fr, I'll investigate further  ;)
Pete Vickerstaff
Linux Mint 21.2 Cinnamon, Windows 10, Lazarus 3.2, FPC 3.2.2

petevick

  • Sr. Member
  • ****
  • Posts: 374
Re: not responding message at breakpoint
« Reply #3 on: May 06, 2024, 11:55:38 am »
for anyone who has the same issue in Linux Mint, the solution is as follows...
run dconf-editor
go to the org/cinnamon/muffin folder
click the check-alive-timeout entry
turn off 'Use default value'
enter the new value in the 'Custom value' field, I used 60000, which is 1 minute.
Pete Vickerstaff
Linux Mint 21.2 Cinnamon, Windows 10, Lazarus 3.2, FPC 3.2.2

 

TinyPortal © 2005-2018