Forum > LazReport

Inches instead of mm

(1/3) > >>

More questions...

Was doing to page setup from a report and see that everything is in mm. Any options to have this in inches? Not a big deal but looks odd for folks that are still not on the metric system...




Have you tried setting TfrDesignerForm.Units to ruInches ?

--- Quote from: Thaddy on February 25, 2024, 08:13:20 pm ---2.54

--- End quote ---
That doesn't really help with changing the dialog from mm to inches in LazReport, does it 🤡

Hmm, yes, 2.54 is not much help ;)

@rvk - Not really using the Designer in the app, so don't think that will effect it. I did try it in the tool when I created the report, but no change.

The issue is during run-time preview where you can set page size, margins, etc. The dialog only seems to show mm and can't find an option to do inches. People picking A4 in the USA might not recognize 210mm x 297mm as A4 or common 8.5"x11" paper, as well as margin settings :)

I saw the option in the run time designer to select pixels, inches, or mm for creation of the report, but not for subsequent dialogs that display options on the preview.

Not a huge deal, seems odd that no options for units in the settings for dialogs.


2.54 is helpful if you know your math. you do not need a calculator for that, it least i don't. :o


[0] Message Index

[#] Next page

Go to full version